My.openhab oh2 wont create files

openhab2 intall is at /opt/openhab2 on rpi. cannot get my.openhab to create uuid and secret. have added user openhab and openhab2, unfortunately they also have default passwords…sudo adduser openhab…openhab2

had to specify password, which may be where problem lies…

regardless, added both users to dialout group. have restarted openhab server. have reinstalled my.openhab jar. will not create uuid or secret.

please help. thanks in advance as i have had a lot of help previously from you guys and it has helped a lot!

Hi Branden_Smale,
Did you manage to solve this issue ?
I am also facing a similar issue but in my case uuid file is being created. However, secret file is still not created.
I tried all possible solutions including a fresh install but, no luck! :frowning:

Please help guys



I managed to solve this issue finally :smile:

I just created a new file named secret at the same location where uuid file is present and pasted a randomly generated WEP-128 bit key. Then i updated my account with the same key and magically everything’s got working.

I followed this post!topic/openhab/BbQjka21FlQ

no, and i am surprised someone finally responded. i hope we can get this figured out.

try to start your server in debug mode and maybe you could see some additional logs which might help solve this issue.

I just tried it. Installed my.openHAB addon via Paper UI.
The file userdata/uuid is creates in any case and once the addon is there, I can also see userdata/myopenhab/secret.
Entered both in my my.openHAB account and restarted my runtime I see

21:26:49.605 [INFO ] [o.myopenhab.internal.MyOpenHABClient] - Connected to my.openHAB service (UUID = c77049de-e5d0-45ab-94c6-xxxxxxxxx, base URL = http://localhost:8080)

Did you maybe not look in these locations for the files?

i will try your solution, thx.

@belovictor It would be great if you could put this information on to, because it seems that this is nowhere yet documented for openHAB 2…

1 Like

i created the files at the specified locations and put all info on my.openhab. server is still not communicating with online. i know oh1 had to specify my.openhab as persistence, how to do that with oh2?

WIth OH2 you can go to the paper UI then persistence and Install my.openhab. It’ll create those files for you, not sure if they overwrite what you have already.

ok, i will try it

Thank you,

Branden Smale
Electrical Craftsmanship, Inc. (ECI)
(352) 494-4033

After you install the my.openhab extension (currently found under “MISC”). What is the directory path to the secret file? There is no webapps folder in OH2 nor userdata folder. I have found the UUID via the REST API end point.

UUID Is in the userdata folder.
There should be a myopenhab folder generated in userdata too which will hold the secret file.

Apologies for the ignorance, is the userdata folder under the /etc/openhab2 directory or the /usr/share/openhab2 directory?

I can’t recall off the top of my head (i’m at work now). If it’s not in either of those folders, you could try here: /var/lib/openhab2

Are you installing on a Pi? Via apt-get?

exactly pi2 via apt-get (fresh install as of yesterday)

Ok, Now that I’ve found the UUID and Secret values and updated profile. I restarted the openhab service and see the following log lines (with modified my uuid and secret values). the website still shows “offline”.

2016-08-10 15:00:43.131 [DEBUG] [.myopenhab.internal.MyOpenHABService] - my.openHAB service activated
2016-08-10 15:00:43.145 [DEBUG] [.myopenhab.internal.MyOpenHABService] - Using secret at ‘/var/lib/openhab2/myopenhab/secret’ with content 'YYYYYYYYYYYYYYYY’
2016-08-10 15:00:43.146 [DEBUG] [.myopenhab.internal.MyOpenHABService] - UUID = XXXXXXX-XXXXXXX-XXXXXXX-XXXXXXX-XXXXXXX, secret = YYYYYYYYYYYYYYYY
2016-08-10 15:00:43.166 [DEBUG] [.myopenhab.internal.MyOpenHABService] - Using secret at ‘/var/lib/openhab2/myopenhab/secret’ with content 'YYYYYYYYYYYYYYYY’
2016-08-10 15:00:43.580 [DEBUG] [o.myopenhab.internal.MyOpenHABClient] - No connection, Item update is not sent

Anyone have any ideas?


I am having the same problem. Did you manage to get your setup working?

The first and obvious question: Is your Java up to date? You have to use Oracla Java (not OpenJDK) and at least version 1.8.0-101 of Oracle Java. Otherwise my.openhab will not work.

Java is installed as 1.8.0_65 but when i try to update with apt-get install, then it sais it is currently the newest version

java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) Client VM (build 25.65-b01, mixed mode)

$ sudo apt-get install oracle-java8-jdk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
oracle-java8-jdk is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

By the way I am running openhab on Raspbian with RP3.

Here’s what I have done so far:

With Paper UI added the binding misc/myopenhab, checked with feature:list if installed properly.
Created an account at with secret and uuid that i found in /userdata.

What am I missing?

I have found people suggesting myopenhab.cfg file similar to my.openhab 1.x to give security permissions so I created that as well in …/conf/services with :


Is this correct?

The logs are mostly without myopenhab logs, only if I leave it on for the night do I get a few notices of myopenhab shutting down.