is online // iOS app doesn't show sitemap -> Solution: Java update!

Tags: #<Tag:0x00007f5c8ff8ed80> #<Tag:0x00007f5c8ff8ec40> #<Tag:0x00007f5c8ff8eb00>

(Henry Dammeyer) #47


I’m running OH2 in Eclipse under Windows. August 1st myopenhab stopped working. As per the instructions above, I have upgraded Java to:

java version "1.8.0_101"
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ 64-Bit Server VM (build 25.101-b13, mixed mode) shows online, but I’m still getting:

2016-08-25 15:34:22.036 [DEBUG] [o.i.m.internal.MyOpenHABClient:501 ] - No connection, Item update is not sent

Not sure what else to try, as the letsencrypt instructions are all UNIX based.

I haven’t tried using the 32-Bit Java Server

Has anyone gotten this working under Windows? I really need myopenhab!

Thanks in advance.

(Anton Wedemeier) #48

Thank you for this information.
MyOpenHab stopped on the day I went on holyday. After returning I tried (among other things) you script. I don’t understand what I am doing, but it works. I did not even need to reboot.

(Rob B) #49

On my Debian Wheezy Raspberry Pi 2 I installed using the instructions provided by sihui above
(btw this website
indicated this Ubuntu instruction was good on a Debian installation)
2016-08-29 21:46:24 (583 KB/s) - `jdk-8u101-linux-arm32-vfp-hflt.tar.gz’ saved [81542641/81542641]

Download done.
Removing outdated cached downloads…
update-alternatives: using /usr/lib/jvm/java-8-oracle/jre/bin/jjs to provide /usr/bin/jjs (jjs) in auto mode

and then
Oracle JDK 8 installed
root@robsberrypi:/usr/bin# java -version
java version "1.8.0"
Java™ SE Runtime Environment (build 1.8.0-b132)
Java HotSpot™ Client VM (build 25.0-b70, mixed mode)
update-alternatives --config java
and selected 3 from
Selection Path Priority Status

0 /usr/lib/jvm/java-8-oracle/jre/bin/java 1058 auto mode
1 /usr/lib/jvm/java-6-openjdk-armhf/jre/bin/java 1057 manual mode
2 /usr/lib/jvm/java-8-oracle/jre/bin/java 1058 manual mode

  • 3 /usr/lib/jvm/jdk-8-oracle-arm-vfp-hflt/jre/bin/java 318 manual mode

and still get the same java version as before the update
java -version
java version "1.8.0"
Java™ SE Runtime Environment (build 1.8.0-b132)
Java HotSpot™ Client VM (build 25.0-b70, mixed mode)

And so still getting:
22:26:01.482 [DEBUG] [o.myopenhab.internal.MyOpenHABClient] - No connection, Item update is not sent

Anyone have any suggestions?

my.openHAB offline from July
(Stefan) #50

Whatever you did to update java, I think something went wrong…

When I do a java -version, I’ll get:

root@raspberrypi:/home/pi# java -version
java version "1.8.0_101"
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ Client VM (build 25.101-b13, mixed mode)

So you have 1.8.0-b132, which is different to 1.8.0_101-b13. I am not familiar with java versions, but this is clearly another version. :wink:

Furthermore your HotSpot Client VM version is different to you RE version. Doesn’t know if this matters at all, but at least it’s strange.

All people with working installations have version 101, so you should try to grab this version.

(Rob B) #51

Thanks for your reply.

That was what I was trying to update to:
`jdk-8u101-linux-arm32-vfp-hflt.tar.gz’ saved

After the installation it reports the same version even after I select the new version from
update-alternatives --config java

OK - got it.
I ran that same command again and selected the 0 option and now have:
java version "1.8.0_101"
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ Client VM (build 25.101-b13, mixed mode)

(Jean Christophe Duperron) #52

Awesome this is PERFECT.
All this time I thought that my Java was ok but after finally tried to upgrade to the last manually (I was thinking that apt-upgrade that…) Everything is working flawless!

And of course you point me how to automatically upgrade it for next java update!

I luv you!

(Aiko) #53

For everyone who need JAVA 1.8.0 101 here is a description
and here you get the Archiv Java version

You need an Oracle Account to download this file. Download this one: Linux ARM 32 Hard Float ABI

Now to my problem. I have now the correct JAVA version running but my openhab is still marked as offline. One ideas what it won’t worked.
I restart openhab and the pi a many times.

(SiHui) #54

Meanwhile its 1.8.0_111 :slight_smile:

Which version of openHAB? The file location for uuid and secret is different from version 1 and version 2. Double check you have the correct uuid and secret put into your my.openhab account.

For openHAB1 see

For openHAB2 see

(Aiko) #55

I have openhab 2 running. The UUID and the secret key is correct at my my.openhab account.

What’s really confuse mit is that in the openhab.log is nothing about myopenhab or my.openhab.

Could there be a problem with the installation of the addon with paperUI?

(SiHui) #56

There should be a

2016-12-11 05:00:21.373 [INFO ] [o.myopenhab.internal.MyOpenHABClient] - Connected to my.openHAB service (UUID = aaaaaaa-bbbb-cccc-dddd-eeeeeee, base URL = http://localhost:8080)

Check under “Misc” tab if it is installed correctly

or if you want to make sure if it is really running log into your karaf console via ssh, do a bundle:list

197 | Active | 80 | | my.openHAB Service Bundle

(Aiko) #57

231 | Active | 80 | | my.openHAB Service Bundle

looks ok but in the log is since the last restart nothing about my.openhab

(Aiko) #58

I did a bundle:restart 231
231 was my.openhab

now i got this in the log

2016-12-11 09:41:22.051 [INFO ] [o.myopenhab.internal.MyOpenHABClient] - Shutting down my.openHAB service connection

(SiHui) #59

Are you sure you are on a java version later than 101?

pi@raspberrypi3:~ $ java -version
java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) Client VM (build 25.111-b14, mixed mode)

(Aiko) #60

That’s my output.

pi@jarvis:~$ java -version
java version "1.8.0_101"
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ Client VM (build 25.101-b13, mixed mode)

(SiHui) #61

Looks good … sorry, no more ideas…

(Aiko) #62

Ok danke für die Hilfe :slight_smile:

Maybe someone different could help me :sweat:

(Aiko) #63

just an information for other people with some problem.

I switched from my.openhab to myopenhab and use the openhab cloud connector for remote access.

(mrwhale) #64

For those that don’t want override apt-get install of java, and faff about with manually installing java.

As someone mentions at the start of this topic, installing the lets encrypt cert to the java cert store works nicely, so this is an alternate (and slightly easier ) method of getting working again! Currently the latest java out in the raspberry pi repository is 1.8.0_65, so you have to do a manual installed (as suggested in this thread) of java 1.8.0_101+

sudo keytool -trustcacerts -keystore /usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre/lib/security/cacerts -storepass changeit -noprompt -importcert -file isrgrootx1.pem -alias letsencrpyt1
sudo keytool -trustcacerts -keystore /usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre/lib/security/cacerts -storepass changeit -noprompt -importcert -file lets-encrypt-x3-cross-signed.pem -alias letsencrpyt2
sudo systemctl restart openhab

Some explanation.
First 2 wget's are just getting the cert chain from lets encrypt (

Second 2 commands are importing these chains into java’s certificate store. You will just need to modify the path to be where your java is installed. This path was the default path from the apt-get installation of oracle java (this should be accessible via $JAVA_HOME environment variable)

and of course, things will not start working until you do a reboot

TimeOutError when using "HttpUtil.executeUrl"
(Sutdiphan Moongvicha) #65

After rebooting my.openhab2 on Pi3 is Online. Thank you.

(kamel reddad) #66

thank you for your help