My.openhab.org is online // iOS app doesn't show sitemap -> Solution: Java update!

ios
my.openhab
java
Tags: #<Tag:0x00007f0146c4a178> #<Tag:0x00007f0146c49fe8> #<Tag:0x00007f0146c49e80>

(Stefan) #1

Hi guys,

today I noticed that my (previously working perfect) remote connection of my iOS app with my.openhab doesn’t work anymore. Local mode is working.

Interestingly, when I send a notification message through my.openhab, this message is delivered correctly to the device (even in remote mode). But the sitemap simply doesn’t show up and I get an “Error: connection timed out”.
My.openhab.org also shows “Online”.

And for the records: It has worked yesterday and I didn’t make any changes to my environment… :wink:

Furthermore, my log file says that my.openhab regularly disconnects every 4 hours and then reconnects immediately. This is the “normal” behavior. But at 6pm it as disconnected and not connected yet again.

Anyone with the same issues? Or is it a local problem of my installation?

Greetings,
Stefan


My.openhab: openHAB is Offline
My.openhab not working
Can't get OH remote access with my.openhab.org
Problem setting up myopenhab service on openhab2 installed on windows 10
My.openHAB connectio Failed
My.openHAB connectio Failed
Myopenhab not loading
myopenHab
My.Openhab Setup Errors
[SOLVED] Your openHAB is not online tried everything
TimeOutError when using "HttpUtil.executeUrl"
[Solved] Cloud service problem
[SOLVED] MyOpenhab says OFFLINE
Is my.openhab offline?
Help - Raspberry Pi 3 openhab instalation instructions
Openhab2 iphone remote access setup
(Victor Belov) #2

This is probably caused by certificate change today. I’m looking into it now. Have no idea how it could affect though…


(Chuck Connors) #3

+1 … Having the same problem connecting with my.openhab.org but can connect fine directly on my local network (not through my.openhab.org).


(SiHui) #4

Same here …


Zwave binding / FGFS101 Flood Sensor issues
(Stefan) #5

I’m glad I’m not the only one…

Thanks for investigating @belovictor!


(Victor Belov) #6

Ok. It took some time. And it is a problem after we upgraded certs on my.openhab.org. The old one was expiring today so we switched to letsencrypt.org certs and this was causing the problem. The same happened to myself. As soon as I upgraded java to latest 1.8 version on my opehab’s machine everything started working. So I assume this is an old standing problem - Oracle Java uses it’s own keystore instead of system one and there simply were no CA for letsencrypt.org there :frowning:
So I recommend that everybody who experience this problem upgrade to the latest Java version.
Sorry for the inconvenience!


OH2: my.openHAB stays offline
Once more, my.openHab offline
My.openhab won't load related to infrequent Java crashes?
(Stefan) #7

Thanks Victor!

According to java -version I have the following version installed:

java version "1.8.0_65"
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode)

I don’t remember exactly how I installed it, but I assume it was via apt-get. So I thought this will be automatically updated with apt-get update && apt-get upgrade. Isn’t this the newest version? And if not, how can it be manually updated?


(Stefan) #8

Got it updated to 1.8.0_101-b13 and now it seems to work again. I still get some weird java error in my log, but this seems to be because of an uninitialized item.


My.openhab persistence not working
(Victor Belov) #9

I just pushed an e-mail to all my.openHAB users describing the problem and possible ways to sort it out. You can either upgrade to the latest 1.8 or add letsencrypt.org certs to Java keystore manually using keytool.


HABDroid has stopped working
(Roy Knowles) #10

Hi Stefan,

How did you finally get the update?


(Joe) #11

@Roy, I followed the instructions at the link below and now it works on my RPi 2.


(Stefan) #12

I simply installed the newest version according to Udo’s posting (#20) in this thread:

https://community.openhab.org/t/java-version-1-8-required-still-wont-start/10762/19


Installation page (wiki) needs updating
(SiHui) #13

I did -almost- the same, but used the WebUpd8 installer in @Udo_Hartmann link to get automated java updates in the future (I wasn’t aware that this is not done automatically through apt-get update/upgrade on a Raspbian Jessie installation on a Raspberry Pi), but you have to make a slight change to the tutorial: instead of su - use sudo su:

sudo su
echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee /etc/apt/sources.list.d/webupd8team-java.list
echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main" | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886
apt-get update
apt-get install oracle-java8-installer
exit

After rebooting my.openhab started working again.


Securing Openhab with free ssl Let's Encrypt Certificates
My.openhab connection stopped working on 8/1/16
Openhab offline and "No Connection" log message
Another my.openhab.org shows offline problem
Repeated "xhr poll error" when trying to connect to my.openhab under openhab2
My.openhab won't load related to infrequent Java crashes?
Upgrade to Latest Java
Java update
New folder structure
openHAB is offline message [fixed]
My.Openhab - No connection, Item update is not sent
My.openhab configuration in OH2
Once more, my.openHab offline
My.openhab is offline
OpenHab is OFFLINE again? HELP?
(Federico) #14

Yes, in my case too a reboot was necessary, thanks.


(Roy Knowles) #15

Hi Joe,

Thanks for the link, all up and working again.

roy


(Shorty707) #16

hey there
i had java 1.8.0 on my pi2 before already
but still my.openhab stays offline :frowning:


(Peter) #17

When you put java -version in to the terminal what version is it saying you have?


(Shorty707) #18

pi@raspberrypi ~ $ java -version
java version "1.8.0"
Java™ SE Runtime Environment (build 1.8.0-b132)
Java HotSpot™ Client VM (build 25.0-b70, mixed mode)
pi@raspberrypi ~ $ javac -version
javac 1.8.0
pi@raspberrypi ~ $


(Joe) #19

You should use the instructions at the link I posted above. Those instructions will update you to 1.8.0_101-b13 (you’re currently at 1.80-b132),


(Peter) #20

I believe that’s an outdated version. Try using the WebUpd8 installer that @sihui posted.

and then reboot and you should be good to go.