Use OpenHAB Cloud Connector to send notification

I am trying to setup openHAB Cloud Connector but it keeps telling me I’m offline

I checked the log and it says

2019-03-30 23:09:00.082 [WARN ] [o.openhabcloud.internal.CloudService] - You are running Java 1.8.0_65 - the openhab Cloud connection requires at least Java 1.8.0_101, if your cloud server uses Let’s Encrypt certificates!
2019-03-30 23:12:02.259 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection

I tried searching how to update to java 1.8.0 101 but can’t find the commands for raspberry pi.

Also it gives an error when I try to send a notification using this

var NotificationAction =;
NotificationAction.sendBroadcastNotification(“This is a broadcast test”);

The error is

java.lang.RuntimeException: java.lang.ClassNotFoundException:
at jdk.nashorn.internal.runtime.ScriptRuntime.apply( ~[?:?]

Caused by: java.lang.ClassNotFoundException:
at jdk.nashorn.internal.runtime.NativeJavaPackage.classNotFound( ~[?:?]
at jdk.nashorn.internal.scripts.Script$15$^eval_.:program(:2) ~[?:?]
at jdk.nashorn.internal.runtime.ScriptFunctionData.invoke( ~[?:?]
at jdk.nashorn.internal.runtime.ScriptFunction.invoke( ~[?:?]
at jdk.nashorn.internal.runtime.ScriptRuntime.apply( ~[?:?]

I don’t know if the Java version is causing the notification not to be sent, if not how would I fix that?

my.openhab won’t work at all with that old java version.

Please use the search function in this forum, there are many topics about that.

I’ve tried searching but none give simple and easy to follow instructions on how to simply update to the 101 version.

Make sure you are using version 8, not the newest verison 11 (not yet fully working with openHAB)

Does your method from that post only give java 8 updates when they are released? I got it to update and it works now but my notifications still aren’t sending, do you know the problem there?

Log says

Caused by: java.lang.ClassNotFoundException:

Notifications are enabled (see “Mode”)?

They are enabled, I have it set to notifications and remote access.

Then I have no more ideas, sorry.