My.openhab.org is online // iOS app doesn't show sitemap -> Solution: Java update!

Either way works. They both get you to 1.8.0_101.

Hi, same problem. I’m running Openhab on a Mac.

I have updated Java as per normal Mac reminders, and get the following when I run ‘java -version’:

java version "1.8.0_102" Java(TM) SE Runtime Environment (build 1.8.0_102-b14) Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

I also downloaded JDK 1.8 from Oracle site and installed it, and I rebooted the Mac. But my iOS app can still not get the sitemap remotely, where it was working previously. I can get it on the same phone if I go to http://my.openhab.org/openhab.app.

Any ideas for Mac?

I think it is the iPhone app, because I have the same issue and my OpenHab is on a Windows box. After I updated Java it works on the browser but the app still fails.

Does it work if you select “ignore SSL certificates” in the settings of the iOS app?

Same issue here, Java update fixed it. Thanks!

I just updated Java according to the WebUpd8 method.
But now my IHC binding dosen’t work :frowning2:
Anybody how can guide me how to remove the newest java version again?

I found the app was working on my iPad, not on my iPhone. I tried “Ignore SSL certificates” and “Clear cache” with no luck.

I deleted the app on my iphone, reinstalled it and now it works.

Hi, I have just updated Java, and that has fixed the myOpenHab problem. However, the NetAtmo binding will stop working because new Java comes with new keystore and you also need to add the Starcom certificate to the new keystore. There may be other bindings using certificates as well, but I did not check that. So if a binding stops working, check if it needs a certificate.

Is there a method that doesn’t require a graphic interface? My pi is located away from any sort of screen at the moment, so I only have SSH access through my phone. Apt-get seems to only update me to 1.8.0_65.

Ok, so I accidentally installed v1.7.0_101. I uninstalled that. Uninstalled v1.8.0_xxx. Then reinstalled v1.8 using apt-get. “Java -version” still says I’m using v1.7.0_101. I don’t know what version I’m really using, but openHAB is allowing me to connect remotely again. I’ll figure it out later. Thanks for all the info in this thread!

I’m in the same boat as you. My RPi 2 is headless with only SSH access. I used those instructions on my Mac SSH’d into the RPi.

@Steve40: You don’t need a graphic interface. SSH access is enough to update/install the recent java version. The instructions of sihui should do the job!

All who have problems: Maybe the correct version is already installed, but not activated. Try

sudo update-alternatives --config java

to check, which versions are installed and which one is activated. You can have different versions installed at the same time (or Oracle Java and Open JDK at the same time). If so, you have to choose the right version with this command.

1 Like

hi all,

that tutorial from sihui works great for my RasPI3!! and my openhab 1.8.3 version!

many thx to sihui

greets, eibalinchen

Thx, appreciation goes to @Udo_Hartmann for sharing the link … :ribbon:

I’ve followed these instructions and that brought myopenhab back online…thanks for that.

I do have a problem where the web interface is no longer working (but HabDroid is).

Anyone else get this?

Problem accessing /start/index. Reason: Not Found

2016-08-06 10:06:23.612 [WARN ] [eclipse.jetty.servlet.ServletHandler] - /proxy java.nio.channels.ClosedChannelException at org.eclipse.jetty.io.WriteFlusher.onClose(WriteFlusher.java:482)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.AbstractEndPoint.onClose(AbstractEndPoint.java:109)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.AbstractEndPoint.close(AbstractEndPoint.java:116)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.ChannelEndPoint.close(ChannelEndPoint.java:113)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.SelectChannelEndPoint.close(SelectChannelEndPoint.java:168)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.AbstractConnection.close(AbstractConnection.java:225)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.SelectorManager$ManagedSelector.closeNoExceptions(SelectorManager.java:723)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.SelectorManager$ManagedSelector.access$1100(SelectorManager.java:406)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.SelectorManager$ManagedSelector$EndPointCloser.run(SelectorManager.java:1030)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)[81:org.eclipse.jetty.util:9.2.14.v20151106] at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)[81:org.eclipse.jetty.util:9.2.14.v20151106] at java.lang.Thread.run(Thread.java:745)[:1.8.0_65] 2016-08-06 10:06:23.618 [WARN ] [org.eclipse.jetty.server.HttpChannel] - /proxy?sitemap=default.sitemap&widgetId=0800&t=11807784156069734 javax.servlet.ServletException: java.nio.channels.ClosedChannelException at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(JettyServerHandlerCollection.java:88)[164:org.ops4j.pax.web.pax-web-jetty:4.2.4] at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)[78:org.eclipse.jetty.server:9.2.14.v20151106] at org.eclipse.jetty.server.Server.handle(Server.java:499)[78:org.eclipse.jetty.server:9.2.14.v20151106] at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)[78:org.eclipse.jetty.server:9.2.14.v20151106] at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)[78:org.eclipse.jetty.server:9.2.14.v20151106] at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)[81:org.eclipse.jetty.util:9.2.14.v20151106] at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)[81:org.eclipse.jetty.util:9.2.14.v20151106] at java.lang.Thread.run(Thread.java:745)[:1.8.0_65] Caused by: java.nio.channels.ClosedChannelException at org.eclipse.jetty.io.WriteFlusher.onClose(WriteFlusher.java:482)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.AbstractEndPoint.onClose(AbstractEndPoint.java:109)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.AbstractEndPoint.close(AbstractEndPoint.java:116)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.ChannelEndPoint.close(ChannelEndPoint.java:113)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.SelectChannelEndPoint.close(SelectChannelEndPoint.java:168)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.AbstractConnection.close(AbstractConnection.java:225)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.SelectorManager$ManagedSelector.closeNoExceptions(SelectorManager.java:723)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.SelectorManager$ManagedSelector.access$1100(SelectorManager.java:406)[70:org.eclipse.jetty.io:9.2.14.v20151106] at org.eclipse.jetty.io.SelectorManager$ManagedSelector$EndPointCloser.run(SelectorManager.java:1030)[70:org.eclipse.jetty.io:9.2.14.v20151106] ... 3 more 2016-08-06 10:06:23.623 [WARN ] [org.eclipse.jetty.server.HttpChannel] - Could not send response error 500: javax.servlet.ServletException: java.nio.channels.ClosedChannelException 2016-08-06 10:07:02.326 [INFO ] [enhab.io.squeezeserver.SqueezeServer] - Squeeze Server connection started. 2016-08-06 10:07:05.434 [WARN ] [org.apache.karaf.shell.ssh.Activator] - Exception caught while starting SSH server java.net.BindException: Cannot assign requested address at sun.nio.ch.Net.bind0(Native Method)[:1.8.0_101] at sun.nio.ch.Net.bind(Net.java:433)[:1.8.0_101] at sun.nio.ch.Net.bind(Net.java:425)[:1.8.0_101] at sun.nio.ch.AsynchronousServerSocketChannelImpl.bind(AsynchronousServerSocketChannelImpl.java:162)[:1.8.0_101] at org.apache.sshd.common.io.nio2.Nio2Acceptor.bind(Nio2Acceptor.java:66)[1:org.apache.sshd.core:0.14.0] at org.apache.sshd.common.io.nio2.Nio2Acceptor.bind(Nio2Acceptor.java:74)[1:org.apache.sshd.core:0.14.0] at org.apache.sshd.SshServer.start(SshServer.java:287)[1:org.apache.sshd.core:0.14.0] at org.apache.karaf.shell.ssh.Activator.doStart(Activator.java:117)[57:org.apache.karaf.shell.ssh:4.0.4] at org.apache.karaf.util.tracker.BaseActivator.run(BaseActivator.java:233)[57:org.apache.karaf.shell.ssh:4.0.4] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.0_101] at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_101] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_101] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_101] at java.lang.Thread.run(Thread.java:745)[:1.8.0_101]

@sihui
I am not sure if I got you right.

You mean, Ijust need to run your script above (or single commands) to update java with the next apt-get upgrade to the required version?

Yes, just copy the whole stuff at once to a command prompt and hit enter.
You could do it with single commands, but then you have to remove the “echo” and quote signs …

Thanks, it worked like a charm. :slight_smile:

Hi,
I have the same problem with my netatmo.
Could you please share some information / link how to proceed with the certificate issue?
Thanks

Doh!
Found it in the Netatmo wiki.
Never mind. :wink: