"My Raspberry Pi is experiencing issues with its initial startup on OpenHAB."

Hello, I just bought a Raspberry Pi 5 for my home automation setup with OpenHAB. I’ve burned OpenHAB 64-bit image onto my 128-gigabyte SD card, but the issue is when I insert the card into my RPI5, nothing happens.

I’ve connected it to my router via an RJ45 cable, and the router to my laptop also via an RJ45 cable.

The problem is, I can see my laptop on the router’s utility, but not the RPI5. So, I’m not sure what else to do to get it working.

If you could help me, I would appreciate it.

Try setting up the RPI using oem software and make sure its not a hardware issue first.

It’s possible that the issue is related to the configuration file. When I insert the SD card into my computer, I notice that the IPv6 protocol is enabled, whereas my router’s DHCP only assigns IPv4 addresses.

To get the best information about what is going on with the RPi, plug it into a monitor and see what the errors are. That will tell you for sure why it’s failing to come up and perhaps point to a solution.

openHABian should support IPv4 so I don’t think that IPv6 is going to be the root cause of the problem.

Note that there is some configuration you can do to openHABian before that first boot related to networking. Did you change any of those first boot settings? openHABian | openHAB

Indeed, I didn’t change a setting, I just flashed and inserted it into my RPI5. But I was also thinking, since my router doesn’t have internet access, I’m currently using it only locally with my RJ45 cables. Could this interfere with the installation process due to the lack of internet? I think I’ll see if I can then modify the network settings, as I currently don’t have a screen available.

Absolutely. Internet access is required. openHABian is a series of scripts to download and install openHAB along with other supporting information. I’m not sure that would prevent it from getting an IP lease from DHCP, but it definitely will prevent openHABian from working.

If you want to set this up offline, you cannot use openHABian. You’ll have to do a manual install: openHAB on Linux | openHAB

Ouattara, please read about the prerequisites and install instructions in the docs first.
It’ll also tell you to move on to the DEBUG guide.

You should be seeing an IP assigned to your Pi on your router/DHCP server, and you can watch the install progress on :81
You can also access the box using that ip. The install log is in /boot/first-boot.log .

Yes of course for the full experience you need internet.
(a router without internet uplink isn’t really a router, is it ?)

Well not necessarily. It’ll work somehow without inet, the install script will give up waiting for inet after about an hour and continue by installing the packages that are contained in the image, openhab being one of them of course.
But I believe some of the stuff (like ZRAM which is enabled by default) requires live retrieval from internet so installing may halt or fail or at least you will not be getting the full experience.

Right, but if the router is saying that it’s not assigned an IP and there is no other indication that it made it online that means it’s not on the network and will never let anyone see the progress on port 81. That’s why I recommended the monitor. If it doesn’t even get an IP there really is no other option.

haha, if OP has at least 2 VLANs then it is a router… please… I came across a core router with 3000 incoming cables, and no internet on that network