MyOpenhab always OFFLINE


(Pierluigi Patuelli) #1

I am not able to solve the problem … the UUID & SECRET are correct and the JVM is the Oracle’s one …
Here my DEDUG LOG …

2018-03-24 09:59:14.338 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr open GET: https://myopenhab.org/socket.io/?EIO=3&transport=polling
2018-03-24 09:59:14.340 [DEBUG] [ngineio.client.transports.PollingXHR] - sending xhr with url https://myopenhab.org/socket.io/?EIO=3&transport=polling | data null
2018-03-24 09:59:14.526 [DEBUG] [io.socket.engineio.client.Socket ] - socket error io.socket.engineio.client.EngineIOException: xhr poll error
2018-03-24 09:59:14.529 [DEBUG] [io.socket.client.Manager ] - connect_error
2018-03-24 09:59:14.531 [DEBUG] [io.socket.client.Manager ] - cleanup
2018-03-24 09:59:14.535 [DEBUG] [io.socket.client.Manager ] - reconnect attempt error
2018-03-24 09:59:14.538 [DEBUG] [io.socket.client.Manager ] - will wait 5000ms before reconnect attempt
2018-03-24 09:59:14.540 [DEBUG] [io.socket.engineio.client.Socket ] - socket close with reason: transport error
2018-03-24 09:59:14.543 [DEBUG] [t.engineio.client.transports.Polling] - transport not open - deferring close


(Jürgen Baginski) #2

Which java version do you have installed?
It should be at least: java version “1.8.0_101”


(Pierluigi Patuelli) #3

It is …
java version “1.8.0_65”
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode)


(Jürgen Baginski) #4

In this case you have found the reason! You need to update your java version!


(Pierluigi Patuelli) #5

:wink: I’ll try …


(Pierluigi Patuelli) #6

If I use apt-get update the java version is the same …


(Jürgen Baginski) #7

have a look in here.


(Pierluigi Patuelli) #8

java version “1.8.0_161”
Java™ SE Runtime Environment (build 1.8.0_161-b12)
Java HotSpot™ Client VM (build 25.161-b12, mixed mode)

And it works!

I used the following instructions:

Thanks!


(max) #9

Hello,

I think it’s better to write here instead of opening a new thread:
I have the same problem: Openhab Cloud always says offline.
I’ve installed the Cloud Plugin using the PaperUI and registered my account using the UUID and secret.

I now also updated my java version to: 1.8.0_152, but still not working.

Hope you have ideas!


(Jürgen Baginski) #10

Did you respond to the email to verify your registration?
Did you restart OH?
Did you logout from the myopenhab site and login again?


(max) #11

Yes, I’ve done that.


(max) #12

Maybe it’s caused by this:
When i type in java -version this is the output:

openjdk version "1.8.0_152"
OpenJDK Runtime Environment (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 1.8.0_152-b76)
OpenJDK Client VM (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 25.152-b76, mixed mode, Evaluation)


(Jürgen Baginski) #13

I have exactly the same and I’m online.
How did you configure the myopenhab cloud in PaperUI?
Did recheck- triplecheck that your secret and uuid is correct?


(max) #14

I’ve checked the UUID and the secret several times.

I’ve installed the Myopenhab cloud in PaperUI using the Addon Manager and use the settings, which you can see on the screenshot.

Hope anyone can help me.


(Jürgen Baginski) #15

What does the log say when starting OH concerning the connection to the cloud?