Myopenhab and OH3: Always OFFLINE?

  • Platform information:
    • Hardware: armv7l GNU/Linux
    • OS: Debian 9 (Stretch)
    • Java Runtime Environment: 11
    • openHAB version: 3.0.0
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    Have read all I can on this forum … but still will not work. Have done the following (in this order). Also did this … did not help: openhab-cli clean-cache
  1. OH3 -> Settings -> Misc -> Add -> OpenHAB Cloud Connector
  2. Wait until I see these files appear: /var/lib/openhab/uuid and /var/lib/openhab/openhabncloud/secret
  3. Reboot
  4. Visit myopenhab.org. Create acct using the UUD and Secret. Email arrives for authentication
  5. Login to myopenhab
  6. Status is always OFFLINE.
  • If logs where generated please post these here using code fences:
    :/var/log/openhab# more openhab.log
    2020-12-31 13:19:07.797 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to ‘Australia/Perth’.
    2020-12-31 13:19:07.958 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to ‘-32.02732708763323,115.77975690364839’.
    2020-12-31 13:19:07.970 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to ‘en_AU’.
    2020-12-31 13:20:08.363 [INFO ] [.core.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
    2020-12-31 13:20:20.777 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.
    2020-12-31 13:20:28.726 [INFO ] [org.openhab.ui.internal.UIService ] - Started UI on port 8080
    2020-12-31 13:20:31.807 [WARN ] [rg.openhab.core.io.net.exec.ExecUtil] - Failed to execute commandLine '[/usr/bin/arping -I eth0, --help]

    2020-12-31 13:20:33.513 [INFO ] [ternal.dhcp.DHCPPacketListenerServer] - DHCP request packet listener online
    2020-12-31 13:20:38.441 [INFO ] [.transport.mqtt.MqttBrokerConnection] - Starting MQTT broker connection to ‘mqtt’ with clientid 609a6136
    -4258-4675-9682-93470fd8dd7e
    2020-12-31 13:20:47.386 [INFO ] [ab.ui.habpanel.internal.HABPanelTile] - Started HABPanel at /habpanel

I had to restart openHAB after updating the uuid and secret in the myooenhab.org account.

Thanks Rich. But rebooting my openhab computer did not help.

Seems flakey.

Never seen that WARN before, any ideas what is causing that line? Since it is network related it may be a clue as to what is wrong. Have you selected the network that openHAB uses by default? it is under settings>network settings. Maybe you have mutliple NICs and the wrong one is selected? Are you running in Docker or anything else that may be blocking network traffic?

I find I have to hit SAVE in this screen for it to work, perhaps that does what rebooting does for Rich.

1 Like

Matt:

Appreaciate the suggestions.

  1. the arping warning is related to this which I use to PING device(s) to detect network presence. (It is working by the way)
    UID: network:pingdevice:c353fc35a3
    label: Robs Phone Thing
    thingTypeUID: network:pingdevice
    configuration:
    hostname: MI5s-MiPhoneRob.lan
    refreshInterval: 5000
    retry: 1
    timeout: 3000

    image

  2. Settings Network.
    All looks fine. Only one network interface on the device.
    Screenshot 2021-01-02 113518

  3. Running in Docker? Nope. Outbound traffic is working (eg the PING tests work) and when I install things like bindings (which I assume?? are downloaded from the Internet) = all good. And this works fine from the openHAB computer CLI:
    root@MQTT:~# ping myopenhab.org
    PING myopenhab.org (139.162.151.221) 56(84) bytes of data.
    64 bytes from li1418-221.members.linode.com (139.162.151.221): icmp_seq=1 ttl=51 time=348 ms

    And inbound traffic seems OK as I can access the openHAB GUI from a separate computer on the LAN.

  4. And here is my openHAB Cloud settings. Saved/Rebooted multiple times.
    Screenshot 2021-01-02 114211

So … no idea what is configured wrong on my side.

It may pay to uninstall the cloud connector and then reinstall it, then copy and paste them into the myopenhab website again in case there is a typo or an extra space on the end of something.

Thanks: Done that multiple times. Been carefull on the cut & pastes.

Also deleted my openhab.org acct, and re-recreated.

Is there a log file I can view to see the attempts (and presumed failures) to connect to myopenhab.com?

Hi Rob can you turn on TRACE debugging in the cli, so

log:set TRACE org.openhab.io.openhabcloud

Then restart the binding, like
restart org.openhab.io.openhabcloud

And see if anything interesting is printed in the logs ?

Dan,

Oh ! That helps. Here is what I see

2021-01-02 17:29:50.780 [DEBUG] [o.openhabcloud.internal.CloudService] - openHAB Cloud connector activated
2021-01-02 17:29:50.790 [DEBUG] [o.openhabcloud.internal.CloudService] - remoteAccessEnabled is not set, keeping value ‘true’
2021-01-02 17:29:50.827 [DEBUG] [o.openhabcloud.internal.CloudService] - Using secret at ‘/var/lib/openhab/openhabcloud/secret’ with content ‘YYYYY’
2021-01-02 17:29:50.836 [DEBUG] [o.openhabcloud.internal.CloudService] - UUID = XXXXX, secret = YYYYY
2021-01-02 17:29:50.870 [DEBUG] [o.openhabcloud.internal.CloudService] - Using secret at ‘/var/lib/openhab/openhabcloud/secret’ with content 'YYYYY ’
2021-01-02 17:29:50.901 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
2021-01-02 17:29:50.908 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS
2021-01-02 17:29:52.308 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
2021-01-02 17:29:52.316 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS
2021-01-02 17:29:54.971 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
[last 2 lines repeat …]

where
XXXXX is my correct uuid and
YYYYY is my correct secret

Any clues there?

Rob

Following…

Team:

FIXED!!

After running Wireshark, identified that my end failed to complete the TLSv1.2 connection to myopenhab.org

Then a lot of googling got me here:

I am NOT running Ubuntu. But this fixed worked. Seems it is a Java issue.

# /usr/bin/printf '\xfe\xed\xfe\xed\x00\x00\x00\x02\x00\x00\x00\x00\xe2\x68\x6e\x45\xfb\x43\xdf\xa4\xd9\x92\xdd\x41\xce\xb6\xb2\x1c\x63\x30\xd7\x92' > /etc/ssl/certs/java/cacerts
# /var/lib/dpkg/info/ca-certificates-java.postinst configure
# shutdown -r now

BTW … environment is as below

# java -version
openjdk version "11.0.6" 2020-01-14
OpenJDK Runtime Environment (build 11.0.6+10-post-Debian-1bpo91)
OpenJDK Server VM (build 11.0.6+10-post-Debian-1bpo91, mixed mode)

# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.13 (n/a)
Release:        9.13
Codename:       n/a

# cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
NAME="Debian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
VERSION_CODENAME=stretch

# hostnamectl
   Static hostname: MQTT
         Icon name: computer
           Chassis: n/a
        Machine ID: 747145a46a815b3bb50e6d8affc8f5c7
           Boot ID: d349197516e14205bbb8a333740866c9
  Operating System: Debian GNU/Linux 9 (stretch)
            Kernel: Linux 3.10.20-ubnt-mtk
      Architecture: arm

Posting here so others may benefit