MyOpenHAB connection error


I’m using OpenHAB with its cloud for more than a year now. My PC has recently kick the bucket and that gave me an extra push to migrate my HA setup to one of my RPi2’s. I followed all of the steps including the Oracle Java installation etc. OpenHAB is currently working fine on my local network but when I try to connect it to my MyOpenHAB account it doesn’t go well.

In the service log I can see an Error message from myopenhab addon / Socket.IO stating “ERROR] [.myopenhab.internal.MyOHClient] - Socket.IO error: not authorized”.

When I login to with my user and try to go to the Account page I get an “internal server error” message. I’ve made the migration from to a few weeks ago with my old PC.

I tried opening a new user account (and activated it with the link provided via mail) and still no joy.

I’ve made sure (couple of times) that the uuid and secret values are correct. Even deleted these files on my RPi so they’ll be created once again and keyed the new values to my cloud account. Nothing works.

I’ve tried the whole procedure several times in the last 3 days just to make sure it’s not a temporary issue.

Is it possible that my account became somehow corrupted? Can someone think of another reason for this problem?


That looks like your java version is too old, you need at least Oracle Java with a version number greater than 101.
Check java -version on your Pi.

Thanks for your response. I’ve already made sure it’s up-to-date and installed the latest version from Oracle.

Here’s the result of java -version:

java version “1.8.0_111”

Any other ideas?


I saw another thread where someone mentioned that he initially took the secret key from /var/lib/openhab2/myopenhab/secret (which didn’t work out), but then recognized that there was another secret key in /var/lib/openhab2/openhabcloud/secret, which worked.

I can’t imagine that there are two secret files in different folder, but other than that, I’ve also no idea.

Wait, one more idea: Did you previously also have installed the old my.openhab service on your pi? If so, please delete all the pieces which are left (binding, cfg file, persistence file).

still same problem here. Could you finally solve it ?