Myopenhab Devices?

I have added my own Iphone as a device when I setup the openhab cloud and can see it in the device list.
Installed the app on my tablet and my wife’s Iphone and connected to the myopenhab cloud. But I can not see these devices in the list.
What could I have done wrong?

Did you actually confirm those devices work via remote connection (not on your wifi)?

My tablet only has wifi. But I did make sure the local url was deleted and it only had the remote filled in.

I do not understand how the registration of an iPhone is working.
I have installed the app and can access my sitemaps.

But I do not see iPhone being registered and also I have difficulties operating some switch using the iPhone app.

Update: I remove the “/” in the url and reconnected. Now it is working.


I have the same problem and i can’t even received the notifications from rules with “sendNotification”

I removed the app, re-installed, removed the “/” from the URL… nothing works.

How do you register devices? I see the device list, but it is empty, with no “add device” option. Everything works, both on wifi and remotely. The only thing not working is sendNotification, which gets logged in myopenhab, but no longer goes to my phone since the switch from my.openhab.

I’m having the same problem. Got one of my devices linked but it only receives notifications if openhab goes online or offline. I have added in some lights with notifications but don’t get any from them.

For me, the problem seemed to be that the app was out of date. Updated, and all is well.

I’m wondering if it would help to try it from someone else’s wifi?

I am running with openHAB cloud own server, and I still do not see my device listed, even though live connection, and I see my sitemaps through the official iOS app.

Tried reinstalling and reconfiguring app, logout-login from openHAB site - still Devices section empty.

Anybody idea? or a suggestion what to debug, how to proceed?


+1 to Marty56 above.

My iPhone 6 was not showing up as a device below my account listing. I went into the Openhab app on the phone and changed the remote URL from:


My iPhone showed up as a registered device almost immediately.


I did this and this fixed the issue of the device not showing up.

This looks like a bug that needs fixed.

@maintainers Where should we file an issue? In the iOS repo or the openHAB cloud repo?

Sounds pretty similar to this issue, so I have simply left a comment on it.

I just migrated to my own private OpenHAB Cloud server, everything is working fine except no notifications, because my devices aren’t getting registered. I’ve tried including/omitting port 443 and the trailing slash, as well as making sure my URL is exactly as shown by the message within OpenHAB Cloud. I tried re-enabling registration, deleting my account and registering a new one with a different password, still no luck.

One thing I notice is that with my Cloud I now have the Jetty response failure warnings any time I hit the Cloud server from my OpenHAB app. I’m wondering if this is interfering with or a result of something going wrong with the device registration process. I haven’t found anywhere that this null Jetty response failure was understood or resolved.

2020-08-29 12:36:32.360 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 188 failed: null
2020-08-29 12:36:32.364 [WARN ] [io.openhabcloud.internal.CloudClient] - Response Failure: null
2020-08-29 12:36:34.222 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 190 failed: null
2020-08-29 12:36:34.227 [WARN ] [io.openhabcloud.internal.CloudClient] - Response Failure: null
2020-08-29 12:36:35.697 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 192 failed: null
2020-08-29 12:36:35.701 [WARN ] [io.openhabcloud.internal.CloudClient] - Response Failure: null

I’m running OH 2.5.7-1 and OpenHAB Cloud downloaded from Github just a few weeks ago. Any suggestions on what else to try?