Myopenhab: No Devices in myopenhab.cloud - OH2

Hallo !

I want to use Alexa. And therefore I regeisterd myOpenhab.org. Everthing works fine. But when I look at the list of devices (https://myopenhab.org/devices) there is only the information “You currently have no devices registered with openHAB Cloud.”

I guess, that I need in this list all the items for Alexa.

So I used Karaf to get more insight. I turned on the Debug-Level for the openhabcloud. And I got the information, that my items are exposed. But I cant find them in myopenhab?

Thank you for your help.

Bernhard

2017-09-30 22:03:19.760 [DEBUG] [org.openhab.io.openhabcloud ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.events.EventSubscriber, org.eclipse.smarthome.model.script.engine.action.ActionService}={component.name=org.openhab.openhabcloud, expose=[alRollershutter, BuB_01bottom, BuB_01top, BuB_02bottom, BuB_02top, r_EG_Buero, gRollershutters, BuC_01top, swEN01A, EnOcean_switch_01B], baseURL=https://myopenhab.org/, service.config.category=io, service.config.description.uri=io:openhabcloud, mode=remote, service.pid=org.openhab.openhabcloud, service.config.label=openHAB Cloud, component.id=6, service.id=139, service.bundleid=189, service.scope=bundle} - org.openhab.io.openhabcloud
2017-09-30 22:03:20.973 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = 811c2a61-xxxxx-4ac4-bd8a-xxxxxxx, base URL = http://localhost:8080)

You don’t need to expose any item to myopenHAB to be used with Alexa, just add the appropriate tagging in your items definition.

@BernhardPeham HMerk is right . You don’t need to expose any item for using it with Alexa.

Be sure that Cloud Connector Service is running correct. Then tag your items that you want to use with Alexa.

I saw that your baseURL is wrong. It should be: https://myopenhab.org
You can find this setting here:
conf/services/openhabcloud.cfg

After setting up correctly it should run.

You then can see all your items here: https://myopenhab.org/rest/items/

Btw: you better remove your UUID in your first post!! This is public!

Thank you. First I had erased parts of the UUID. Thats important.

You are right. I saw the wrong base URL with localhost. But in my openhabcloud.config is:
baseURL="https://myopenhab.org/"
expose=(
“alRollershutter”,
“BuB_01bottom”,
“swEN01A”,
“EnOcean_switch_01B”,
)

Where is this wrong base URL?

https://myopenhab.org/rest/items/ shows:
[{“members”:[],“link”:“https://myopenhab.org/rest/items/gRollershutters",“state”:“NULL”,“type”:“Group”,“name”:“gRollershutters”,“label”:“Rollladen”,“category”:“rollershutter”,“tags”:[],“groupNames”:[]},{“members”:[],“link”:“https://myopenhab.org/rest/items/gBuero”,“state”:“NULL”,“type”:“Group”,“name”:“gBuero”,“tags”:[],“groupNames”:[]},{“members”:[],“link”:“https://myopenhab.org/rest/items/gTemperatur”,“state”:“NULL”,“type”:“Group”,“name”:“gTemperatur”,“label”:“Temperatur”,“category”:“temperature”,“tags”:[],“groupNames”:[]},{“link”:“https://myopenhab.org/rest/items/r_EG_Buero”,“state”:“0”,“stateDescription”:{“pattern”:"%d%%",“readOnly”:false,"options”:

Thanks

Bernhard

Please check the docs how to configure the cfg file:

baseURL=https://myopenhab.org/
mode=remote
#expose=Presence

You may also configure the cloud via PaperUI:

Quote:
http://docs.openhab.org/addons/io/openhabcloud/readme.html

baseURL=https://myopenhab.org/
mode=remote
#expose=Presence

How you fix this base URL

@hmerk
Hi I can’t register other devices besides the main smarthone and my gmail account (which works properly). I need to send alarm notifications to the members of the user family. To register the other devices (smartphone and tablet) on myopenhab. org must you always enter uuid and secret?
Do you also need to install the security certificate?

Don’t know why you ask me personally, but you can register more than one device (smartphone, tablet, etc) with the same gmail account.