504 Gateway Time-out

I moved to and it worked, at first, kindof. loaded and I could control my items.

I added some items to the openhabcloud:expose= line to push their status for use in IFTTT but they never showed up in at all.

Now when I try to go to I get a 504 Gateway Time-out. Is the service down or is it me?

Hello? Anyone else getting a 504 timeout on for their sitemap?

1 Like

I have the same issue. I was using my.openhab before and I had to create a new account on myopenhab. After setting everything up, I am now online, but none of my items show up, and when I try to access my sitemap remotely I get the same error - 504. I just downloaded the latest Java 8 update, that got me online, but now I can’t get anything else to work.

Never got this working on OH1.8 so I have started trying to move to 2.0. The sitemap worked right away in that version.

is anybody else experiencing 504 Gateway Time-out when trying to connect to

504 Gateway Time-out right now.

Same for me. In case you didn’t knew already: There is a status page for the OH services available:

The problem is already mentioned there.

I’ve had this off and on all weekend and this morning Alexa isn’t working because of it. I’m assuming the server is overloaded? I don’t mind running my own but will services (alexa, ifftt) work with another server or does it have to be myopenhab?

I’m also getting 504 Gateway timeout constantly in the last week or so. The status page reports that all services are operational.

I also do have permanently “504 gateway timeout” errors. Does anyone have an solution, or is it a “myopenhab server issue”

Thank’s a lot

Same here - rebooted Openhab instance. checked for upgrade etc. 504 with the NGINX comment below when trying to login on the website. No notifications on the IOS app.

Hello, I can agree.
All worked great for more than a month but about week ago I started to get gateway time-out errors. At start sometimes I managed to get to my sitemap and/or paper UI, but now I can not. Help would be appreciated, Thanks.

EDIT: Sorry, found topick about problems with servers.

Same here, sometimes Gateway timeout 504

iOS App doesnt open the sitemaps / timeout.
If you wait a few minutes, sometimes nearly 10 or 15 minutes the service is reachable again.

This behaviour is since a few days / a week.
At it seems to be onlay, but it isn’t.

Too bad it’s going down so often, I’m also getting 504 error now and then and it’s ruin the experience.

I responded in the other thread too but it took me about an hour to spin up a VPS with myopenhab on it and it’s working great. If you can’t put up with the downtime I would suggest this approach.

I’ve been getting 504 timeout errors for at least 4 days now, Anything on my end I should check?
I have rebooted my server multiple times. Running on Ubuntu 16.04

I also cannot save my HABpanel configs to the server anymore. In the Chrome browser console, I see a HTTP 504 Gateway Timeout error after 30 seconds of the HTTP PUT to the REST service (

The MyOpenHAB status page shows no errors (, I am running OpenHAB 2.1.0 stable.

Issue found, this only occurs when I am logged in via and try to save the layout there. If open my OpenHAB URL locally and save the layout there, it is synced fine.

I was able to tank the layout over by going into the Chrome devtools and copying the JSON contents from the LocalStorage items ‘ls.dashboards’ and pasting it in the ‘local panel configuration (experts only!)’ screen.