says “Your openHAB is offline.”

I am a newbie to OpenHab and first impressions are thumbs up except for spending a good chunk of the day trying to openHab Cloud working as it kept showing as Offline. I was reading several articles on the forums and carefully followed the installation steps. Redid it twice and still no luck. I went through the problems other people have experienced and theres definitely some issue with it even though I had installed Java 8 amongst other things people suggested including cleaning the cache and starting again.

OK so what’s going on? I finally fixed it! I initially had installed OpenHab on my Pi from the prebuilt image file which was all good to go or so I thought. But nope it just didn’t;t work. In the end I wiped the SD card and installed a fresh updated copy of Raspbian on the Pi and I followed the manual installation steps from the bottom up and installed Java 8 again and switched the version over to 8. I then followed the instructions again to create the UUID and Secret code and pasted this into myopenhab profile. Rebooted and its now working!!

Is there something wrong with the OpenHab prebuilt image?

I posted this just in case other people were having issues and were going around in circles.

Stating Java 8 is not enough, please show the result of java -version

Mine shows:
openjdk version “1.8.0_222”
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)