myopenHAB replaces my.openHAB!

I can confirm I’m having the same issue.
504 Gateway Timeout.

EDIT: Was attempting to login with a my.openHAB account. Successfullly created and validated my new account and could log in fine.


For those struggling to find their UUID and Secret. Mine, (APT install on Raspberry Pi) were located at:
/var/lib/openhab2/uuid
/var/lib/openhab2/openhabcloud/secret

I have the same problem. Fresh install, enable the cloud connector, register for an account on myopenhab.org and then it reports my openhab as offline and ‘using 1.x’…

help!

thx

@pieter_de_troyer:

Which OH version (1 or 2)? If OH2, which version (Beta or snapshot)?
Which Java version?
Have you confirmed the registration email?
“Using 1.x” is normal (even if you use 2.0), as long as it hasn’t connected for the first time.
Some people report that it stays offline until they exposed at least one item to myopenhab (can be done in PaperUI if you are using OH2)

Correct, but I agree that this is pretty confusing, so I have just entered an issue for it.

The best thing to do is to look at your local log files to see whether the connection has been established and if not, why not.

found the problem in the mean time, was about to update the post here:
I installed on raspberry pi, and apparently it has an older version of the jdk. The solution was mentioned here:

Using openhab 2 btw.

The GUI doesn’t refresh after uninstall. Are you sure the uninstall didn’t work or is just the GUI telling you it isn’t working?

Everything broke… I don’t know how or why … now i can access only habpanel and basic UI I don’t know where to start to find the issue i’m gonna start a new topic here :

Eh … nah i just found that there are a lot of topic for a server error 500 i’m gonna check that

I have tried searching the community for an answer but either I am jumping around too much or I’m blind and cannot find the answer for myself.

I have installed and started setting up the new OpenHabian for openhab2 after confusing myself so many times doing it other ways, I’m an absolute beginner to all this. Can anyone assist as to where I can find my UUID and Secret so I can tie this to myopenhab?

Thanks

mine are here:

/var/lib/openhab2/uuid
/var/lib/openhab2/openhabcloud/secret

you can also run this to find it, and it will search everywhere

find / -name secret

2 Likes

David,

Thank you thats great!

Particularly the find secret command. Hadn’t came across that one despite umpteen google searches :blush:

Hi guys, where is exactly the file call opencloud.cfg that you guys keep talking about? I can’t find it! Should I create it and save it under services folder

yes

The opencloud.cfg is mandatory? All the values inside are optional…

anything you want to communicate with the servics has to be exposed. see the second post on this thread by watou, and click the configuration link.

Yes, but keep in mind that if you only want to get remote access through myopenhab (for using the Apps), you don’t have to expose any items.

Thank you so much. I was struggling with this issue, some of my items were showing up on myopenhab and some were not and I had no idea why.

I don’t have any items show up in cloud,
Currently I only have openHab Cloud connector, I uninstall my.openHAB, is this right way to do?
I can see my online status from cloud, just no items show up, I have tick 3 items only in cloud connector setting (paper UI), I have checked the log in console, only found log of connected to the openHAB cloud, no items info send in log,

I solved, same as this post

Hi,

I’m quite new to openhab and in particular openhab2 (upgraded last weekend) so please bear with me.
So I installed the cloud connector add-on and setup an account and everything worked fine. For now I only want to use myopenhab for remote access and notifications so I have not done anything with persistence.

Everything worked fine for a couple of days and then I got a notification from myopenhab was offline after a bit of tshooting i find out that the add-on had been uninstalled. So today I reinstalled the add-on (and all stated working again) but just about 30 min later I got the following log entry:

2017-02-02 20:37:56.892 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled ‘openhab-misc-openhabcloud’

I did not do anything with my setup at the time so I have no clue what happened. Has anyone seen something like this before?

All add-ons have been installed using paperui but this is the only one that I have this issue with.

Hi @simpalimpa,

Do you by chance have anything defined within conf/services/addons.cfg or are all entries still in comments in there?
I wouldn’t have any explanation, why an uninstall happens during the runtime without doing anything actively yourself…