myopenHAB replaces my.openHAB!

Tags: #<Tag:0x00007faed1183530> #<Tag:0x00007faed11833f0>

Today, the openHAB Foundation e.V. launched an updated version of the my.openHAB service at a new location, http://www.myopenhab.org . We are requesting all current my.openHAB users to signup as new users on this service as the existing my.openHAB service, operated by the openHAB UG, will shut down on January 31st.

IFTTT integration will remain on the existing service until Friday evening (CET) December 16th, then it will be transferred to the new myopenhab.org site. A new add-on for both openHAB 1.x and openHAB 2.0 is required, you can find the according documentation at http://www.myopenhab.org.

This new service will bring along with it enhanced features like the official openHAB Alexa Smart Home skill (as soon as Amazon publishes it), as well as new hardware and the ability to have the community assist and enhance its capabilities.

We understand this may be an inconvenience to our users over the next month, but we could not be more excited about the future of openHAB and we are very thankful for your support as we continue to grow and build the most advanced smart home platform available!

Another related great news is that the code of myopenHAB is now completely available open-source! The project is called openHAB Cloud, it is based on Node.js and whoever wants to go and host his private instance is now able to do so (and yes, there were quite some requests for that in the past).

You can find a blog post at the Foundation’s blog with some more details and background on all of this.
With it, I would like to encourage everyone from the community, especially people loving and using myopenHAB to consider becoming a member of the Foundation, which will allow us to move forward and further work in the interest of the openHAB community!

Best regards,
Kai

11 Likes

Should the Configuration section for openhab.cfg include openhabcloud: prefixes in the wiki page?

It does :innocent:
Thanks for noticing!

Thanks for this refreshed and improved service! My only comment is it’s sad to see the loss of the convenience of myopenhab.persist to use the * syntax to choose items to expose, but that is minor.

I appear to have successfully switched over my 1.8.3 instance. The Android client was a bit fussy but seems to be connecting now as well.

Great!

Switched on OH2, tested and working ! Nice job !

That’s actually a feature. :slight_smile: People now have to think about what they really want to expose. Besides the data privacy aspect, this is also very helpful to keep the myopenhab server load to a minimum - most downtimes we have seen on my.openhab were due to excessive load on item state updates as many instances simply sent ALL their items - this should now be much better, which should help to have the service up and running without interruptions.

1 Like

I like this aspect. If I forgot to filter out what I wanted then I’d end up with a huge amount of data suddenly appearing online, with loads of events I didn’t want.

1 Like

Hi,
I don’t need to configure any user in my openhab.cfg, do I?

Tried to get it running but get this error in the log:

2016-12-15 17:18:42.853 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2016-12-15 17:18:43.144 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: not authorized
2016-12-15 17:19:00.043 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI
2016-12-15 17:19:15.486 [INFO ] [ore.internal.i18n.LocaleProviderImpl] - Locale set to de_DE
2016-12-15 17:19:16.158 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: not authorized

Any ideas?

Thanks in advance,
Viktor

OK I got it.
The openHAB Secret key changed and is in another directory, so I can’t simply use the old values.

Cheers

Just one heads up. When you switch over you must respond to the “My openHAB account activation” email to verify your email before myopenhab will proxy your UIs. If you fail to do this your OH will show up as online on the web page but when you try to bring up one of the UIs it will say it’s offline.

Beyond that I moved my OH 2 instance over with no problems.

1 Like

I was also first troubled by the same error, I was not aware that I just had to look up the UUID & secret file in /usr/share/openhab/webapps/static

@rlkoshak with me it took some time after clicking on the activation link but now 5 minutes later everything works, hooray

Hello guys,

Im having a problem as myopenHAB says i’m using 1.x version which is not the case and it doesn’t see me online as well.

In the log i get a warning that im using java 8_065 while it requires 8_101…
But it is just a warning.

Any ideas?

yes, I have an idea! Update Java! :wink:

Seriously…if you have 1.8.065 installed, myopenhab will not work. You need 101 at least.

1 Like

org.eclipse.smarthome.core.net ?

2016-12-15 22:20:08.357 [ERROR] [org.openhab.io.openhabcloud         ] - FrameworkEvent ERROR - org.openhab.io.openhabcloud
org.osgi.framework.BundleException: Could not resolve module: org.openhab.io.openhabcloud [234]
  Unresolved requirement: Import-Package: org.eclipse.smarthome.core.net

        at org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]

Please be aware that with openHAB Cloud Connector, you should use your existing UUID and there is a secret in the openhabcloud directory, which you need to add to your account at myopenhab.org.

@Mohamed_Negm you will need to update your java to a newer version, since myopenhab.org uses Lets encrypt and older Java versions dont support it/have problems.

dumb question…

How do we disable my.openhab once we have myopenhab working?

Tom

Just uninstall the my.openhab add-on in the usual way. In oh 1.x delete the jar file from the addons folder. In oh 2 remove it from addons.cfg, uninstall from PaperUI, Habmin, or the karaf console, as appropriate.

Note that the my openHAB.persist file is no longer used and can be deleted.

Working really nicely. Great job!

1 Like

@keule Which OH version are you running and how did you install the connector bundle?

I used the last OH2-snapshot and installed the bundle in the “addons” directory .