Myopenhab shows offline


I just moved from to Proper UUID and secrets are supplied and java -version shows

java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) Client VM (build 25.101-b13, mixed mode)

myopenhab cloud service is also installed but myopenhab still shows offline. This is how my debug looks like:

07:56:10.602 [DEBUG] [io.socket.client.Manager            ] - attempting reconnect
07:56:10.603 [DEBUG] [io.socket.client.Manager            ] - readyState CLOSED
07:56:10.604 [DEBUG] [io.socket.client.Manager            ] - opening
07:56:10.605 [DEBUG] [io.socket.client.Manager            ] - connection attempt will timeout after 20000
07:56:10.607 [DEBUG] [io.socket.engineio.client.Socket    ] - creating transport 'polling'
07:56:10.608 [DEBUG] [io.socket.engineio.client.Socket    ] - setting transport polling
07:56:10.609 [DEBUG] [t.engineio.client.transports.Polling] - polling
07:56:10.610 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr poll
07:56:10.611 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr open GET:
07:56:10.613 [DEBUG] [ngineio.client.transports.PollingXHR] - sending xhr with url | data null
07:56:11.081 [DEBUG] [io.socket.engineio.client.Socket    ] - socket error io.socket.engineio.client.EngineIOException: xhr poll error
07:56:11.082 [DEBUG] [io.socket.client.Manager            ] - connect_error
07:56:11.083 [DEBUG] [io.socket.client.Manager            ] - cleanup
07:56:11.088 [DEBUG] [io.socket.client.Manager            ] - reconnect attempt error
07:56:11.089 [DEBUG] [io.socket.client.Manager            ] - will wait 5000ms before reconnect attempt
07:56:11.091 [DEBUG] [io.socket.engineio.client.Socket    ] - socket close with reason: transport error
07:56:11.091 [DEBUG] [t.engineio.client.transports.Polling] - transport not open - deferring close

Any help would be appreciated.

Did you do the manual login on the myopenhab website AND did you respond to the confirmation email?

Yes I did both

I had similar issues… solved them by logging out from and log back in (website).
After this my myopenhab issues were solved.


Just did that, also restarted openhab server, but no good still :confused:

Are you sure you used the new secret from /userdata/myopenhabcloud instead of the old secret ?

I have an myopenhab folder and not an myopenhabcloud folder.

On myopenhab he says I’m offline and somewhere it states taht I have open
hab 1, instead of 2.04


right now using OH2 and myopenhab I can access my sitemap remotely.
Also event logging is working flawlessly.
IFTTT is not working but I am not expecting this until Tuesday.

It should be userdata/openhabcloud as stated here.

I have/had the same issue but with 1.8.
I activated email and logged on fine and also used the new uuid and secret (but for 1.8)
It kept showing offline in both the sitemap and the account.

I logged on to the site and re-entered the uuid and secret in the account settings and updated. It then managed to get online and after a few minutes started showing the sitemap.

The original UUID and secret were correct but it seemed to fix it. I was getting a different error to you though with unauthorised access. (Socket.IO error: not authorized)

Might help…

I don’t have Configuration->Services->IO->

I have the pine64 download. not the daily builds

does this mean I can’t work with myopenhab?


Yes, I made sure new secret at /var/lib/openhab2/openhabcloud is used. In fact I re-entered them to make sure, logged off and logged in, but still no fun.

I tried what joshpond80 did, entered new uuid and secret, logged off and on, but still no cure.

Btw: I have Base URL for the openHAB Cloud server as in paper UI configurations.
Also tried “” here. Is this correct?

I am having very similar problems. I have a new OpenHAB2 installation on a Synology RackStation. I have some basics up and working including HomeKit integration but I cannot get the cloud service working.

I have:

  1. Installed the OpenHAB Cloud service using paper UI
  2. Created an account at
  3. Verified my email address
  4. Entered the UUID and secret on the website

After some reading I decided to regenerate the UUID and secret so I stopped OpenHAB2, deleted the files and restarted OpenHAB2. I entered the new UUID and secret. Still no joy

I have checked my Java version:
ash-4.3# java -version
openjdk version "1.8.0_101"
OpenJDK Runtime Environment (IcedTea 3.1.0) (linux-gnu build 1.8.0_101-b13)
OpenJDK 64-Bit Server VM (build 25.101-b13, mixed mode)

I don’t see much from the CloudClient in the log. I do see a lot of this very often:

2016-12-20 22:11:43.407 [DEBUG] [io.socket.client.Manager ] - opening <removed URL as I am a new user!>
2016-12-20 22:11:43.407 [DEBUG] [io.socket.client.Manager ] - connection attempt will timeout after 20000
2016-12-20 22:11:43.408 [DEBUG] [io.socket.engineio.client.Socket ] - creating transport 'polling’
2016-12-20 22:11:43.408 [DEBUG] [io.socket.engineio.client.Socket ] - setting transport polling
2016-12-20 22:11:43.408 [DEBUG] [t.engineio.client.transports.Polling] - polling
2016-12-20 22:11:43.408 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr poll
2016-12-20 22:11:43.409 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr open GET:
2016-12-20 22:11:43.409 [DEBUG] [ngineio.client.transports.PollingXHR] - sending xhr with url | data null
2016-12-20 22:11:43.461 [DEBUG] [io.socket.engineio.client.Socket ] - socket error io.socket.engineio.client.EngineIOException: xhr poll error
2016-12-20 22:11:43.461 [DEBUG] [io.socket.client.Manager ] - connect_error
2016-12-20 22:11:43.461 [DEBUG] [io.socket.client.Manager ] - cleanup
2016-12-20 22:11:43.463 [DEBUG] [io.socket.client.Manager ] - reconnect attempt error
2016-12-20 22:11:43.463 [DEBUG] [io.socket.client.Manager ] - will wait 5000ms before reconnect attempt
2016-12-20 22:11:43.465 [DEBUG] [io.socket.engineio.client.Socket ] - socket close with reason: transport error
2016-12-20 22:11:43.465 [DEBUG] [t.engineio.client.transports.Polling] - transport not open - deferring close

One point would be that OpenHAB expects the Oracle Java not the OpenJDK!

My system shows:

:~ $ java -version
java version "1.8.0_101"
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ Client VM (build 25.101-b13, mixed mode)

Thanks. That has fixed it: I need to read more carefully (and not assume official Synology packages are the best). Removed Synology Java 1.8 and installed the Unofficial version that downloads from Oracle. Thanks

Re-installed openhab2-offline again and re-entered new UUID and secret. Installed openHAB Cloud Connector from PaperUI. Still shows offline.

This is what my log looks like:

08:16:55.462 [DEBUG] [io.socket.client.Manager            ] - attempting reconnect
08:16:55.463 [DEBUG] [io.socket.client.Manager            ] - readyState CLOSED
08:16:55.464 [DEBUG] [io.socket.client.Manager            ] - opening
08:16:55.465 [DEBUG] [io.socket.client.Manager            ] - connection attempt will timeout after 20000
08:16:55.466 [DEBUG] [io.socket.engineio.client.Socket    ] - creating transport 'polling'
08:16:55.467 [DEBUG] [io.socket.engineio.client.Socket    ] - setting transport polling
08:16:55.467 [DEBUG] [t.engineio.client.transports.Polling] - polling
08:16:55.468 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr poll
08:16:55.469 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr open GET:
08:16:55.471 [DEBUG] [ngineio.client.transports.PollingXHR] - sending xhr with url | data null
08:16:55.954 [DEBUG] [io.socket.engineio.client.Socket    ] - socket error io.socket.engineio.client.EngineIOException: xhr poll error
08:16:55.954 [DEBUG] [io.socket.client.Manager            ] - connect_error
08:16:55.955 [DEBUG] [io.socket.client.Manager            ] - cleanup
08:16:55.956 [DEBUG] [io.socket.client.Manager            ] - reconnect attempt error
08:16:55.958 [DEBUG] [io.socket.client.Manager            ] - will wait 5000ms before reconnect attempt
08:16:55.959 [DEBUG] [io.socket.engineio.client.Socket    ] - socket close with reason: transport error
08:16:55.960 [DEBUG] [t.engineio.client.transports.Polling] - transport not open - deferring close

Btw I see following error in the top of the log:

2016-12-24 08:34:54.866 [ERROR] [ficate.internal.CertificateGenerator] - Failed to generate a new SSL Certificate. Failed to generate the new certificate.
        at org.eclipse.osgi.internal.framework.BundleContextImpl$[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.internal.framework.BundleContextImpl$[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at Method)[:1.8.0_101]
        at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.internal.framework.BundleContextImpl.start([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.Module.doStart([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.Module.start([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager$[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
Caused by: EC KeyPairGenerator not available

Is this causing the myopenhab offline?

Problem resolved!!!

Please refer to the solution at

I still can’t figure out why mine is offline after reading so many of the solutions. I updated to a new router and changed everything over to the new IP it assigned. Internally everything works great. Most recent Java version and myopenHABcloud still gives me an offline. Getting really frustrated at the moment so just venting a little because with the cloud offline that means Alexa no longer works with it either, which we use religiously anymore. Tried uninstalling the cloud but it won’t through the Paper UI, to see if reinstalling would help. Just can’t see why everything else works remotely except OpenHAB, and yes I did port forwarding. First thing on my list with new router.

Check your Java version. Like me you may have a older version. Also make sure you have Oracle Java not OpenJDK

$ java -version
java version "1.8.0_65"
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode)

You need to have version 1.8.0_101 or later.

I struggled to get the java updated on my PI. I followed these instructions to get the update.

$ sudo apt-get purge openjdk*
$ sudo apt-key adv –recv-key –keyserver EEA14886
$ sudo vi /etc/apt/sources.list

Add these to the bottom. I removed them after the update.
deb trusty main
deb-src trusty main

$ sudo apt-get update
$ sudo apt-get install oracle-java8-installer
$ sudo apt-get install oracle-java8-set-default

$ java -version
java version "1.8.0_131"
Java™ SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot™ Client VM (build 25.131-b11, mixed mode)

After this update myopenhab was showing Online.

1 Like