Myopenhab with CentOS7?

I had a working OH1 installation in Windows, and copied the directory from Windows to CentOS 7 machine.
After some modifications, it’s now working.

However, my.openhab isn’t working yet.
It’s just saying that there is no connection.

I’ve tried deleting uuid and secret files.

Networking is OK at the machine.

Here’s are the details:

$ lsb_release -a
LSB Version:	:core-4.1-amd64:core-4.1-noarch
Distributor ID:	CentOS
Description:	CentOS Linux release 7.2.1511 (Core) 
Release:	7.2.1511
Codename:	Core

$ java -version
java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) Server VM (build 25.111-b14, mixed mode)

And relevant snippet from the log:

17:42:24.485 [INFO ] [c.internal.ModelRepositoryImpl:80   ] - Loading model 'myopenhab.persist'
17:42:34.402 [DEBUG] [.m.i.MyOpenHABServiceActivator:27   ] - MyOpenHAB service has been started.
17:42:34.406 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:299  ] - setEventPublisher
17:42:34.407 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:134  ] - my.openHAB service activated
17:42:34.411 [DEBUG] [.p.internal.PersistenceManager:146  ] - Initializing myopenhab persistence service.
17:42:34.511 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:117  ] - config is null
17:42:34.513 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:175  ] - UUID file found at '/opt/openhab/openhab_distribution-1.8.3-runtime/webapps/static/uuid' with content '044e8a07-1366-4765-8fdf-011632077cb5'
17:42:34.514 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:227  ] - Secret file already exists at '/opt/openhab/openhab_distribution-1.8.3-runtime/webapps/static/secret' with content '...'
17:42:34.515 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:119  ] - UUID = 044e8a07-1366-4765-8fdf-011632077cb5, secret = ...
17:42:34.529 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:175  ] - UUID file found at '/opt/openhab/openhab_distribution-1.8.3-runtime/webapps/static/uuid' with content '044e8a07-1366-4765-8fdf-011632077cb5'
17:42:34.530 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:227  ] - Secret file already exists at '/opt/openhab/openhab_distribution-1.8.3-runtime/webapps/static/secret' with content '...'
17:42:34.531 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:161  ] - Version file found at '/opt/openhab/openhab_distribution-1.8.3-runtime/webapps/static/version' with content '1.8.3'
17:42:34.707 [DEBUG] [.myopenhab.internal.MyOHClient:137  ] - Manager.EVENT_TRANSPORT
17:42:34.826 [INFO ] [c.internal.ModelRepositoryImpl:80   ] - Loading model 'air_condition.rules'
17:42:34.940 [DEBUG] [.myopenhab.internal.MyOHClient:142  ] - Transport.EVENT_REQUEST_HEADERS
17:42:35.191 [DEBUG] [.r.i.engine.RuleTriggerManager:438  ] - Scheduled rule check_temp with cron expression 0 0/1 * * * ?
17:42:35.791 [DEBUG] [riptExtensionClassNameProvider:63   ] - Script actions have changed: ExecActionService, PingActionService, MyOpenHABServiceImpl, AudioActionService, AstroActionService, HTTPActionService, TransformationActionService, 
17:42:36.545 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:281  ] - store(alarmTimeHour), state = 8
17:42:36.546 [DEBUG] [.myopenhab.internal.MyOHClient:477  ] - No connection, Item update is not sent

The only weird thing that I see here, is the config is null - is it normal?


My log file seems similar to the one in [SOLVED] My.OpenHAB OffLine
There @belovictor diagnosed it as an SSL problem, and recommended replacing OpenJDK with Oracle Java.
But I’m already using Oracle Java…
Maybe it’s a problem with my Java version?
My some missing dependencies?
Basically, it’s a “Minimal CentOS” installation.


I’ve tried adding security:option=OFF to openhab.cfg (just for debugging).
Also, I’ve noticed that my system is 64 bit, and I’ve installed 32 bit Java.
So, I’ve removed the old Java, and installed the newest 64 bit version:

$ java -version
java version "1.8.0_112"
Java(TM) SE Runtime Environment (build 1.8.0_112-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.112-b15, mixed mode)

Still, not working.

Verion 1.8.0_112 is late enough to solve the SSL cert problem that could be preventing you from connecting.

When you moved to the new machine, a new UUID and Secret were generated. Did you update your account with these new values? Particularly since you deleted them they should get regenerated the next time the binding starts.