MySensors Binding for OH3

Hello Community

is there already a Mysensors binding for OH3 available?
thanks for answers in advance

The MySensors binding is not part of the official openHAB repository, so you will have to ask the author of the binding themselves on GitHub.

If you don’t want to wait, and have (or switch to) an MQTT Gateway, you can use the MQTT binding in OH3. Here’s an example for OH2.

I just got a Connection to my Sensors on OH3 using mqtt… (mqtt Gateway of mysgw and mqtt Binding of OH3)…Works pretty well

Could you share a simple thing, item…
I try ty connect mysensors (arduino mega) via USB connection.

I’ve worked on a first adaption of the binding for OH3. Feel free to test the version: OH3 - MySensors Binding | MySensors Forum

1 Like

Maybe a stupid question, but sould Mysensors 3.1.0 binding work on Openhab 3.4.5? I installed Openhab 3.4.5 and tried to add Mysensors binding, but I got the following errors:

2023-08-29 20:23:05.471 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.mysensors-3.1.0.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.mysensors [273]
  Unresolved requirement: Import-Package: org.apache.commons.lang; version="[2.6.0,3.0.0)"
	at org.eclipse.osgi.container.Module.start( ~[org.eclipse.osgi-3.17.200.jar:?]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start( ~[org.eclipse.osgi-3.17.200.jar:?]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle( [bundleFile:3.7.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles( [bundleFile:3.7.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess( [bundleFile:3.7.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process( [bundleFile:3.7.4]
	at [bundleFile:3.7.4]