mySensors binding lacking dependencies

just updated form M5 to M6 and the mysensors-2.4.0 Binfing is now failing to initialize:

22:44:29.604 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle:
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.mysensors [203]
Unresolved requirement: Import-Package:

    at org.eclipse.osgi.container.Module.start( ~[org.eclipse.osgi-3.12.100.jar:?]
    at org.eclipse.osgi.internal.framework.EquinoxBundle.start( ~[org.eclipse.osgi-3.12.100.jar:?]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle( [bundleFile:3.6.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles( [bundleFile:3.6.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.startAllBundles( [bundleFile:3.6.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess( [bundleFile:3.6.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.process( [bundleFile:3.6.4]
    at [bundleFile:3.6.4]

Ok, this is a market place binding and the best place to report this issue would be the binding’s gitHub rather than this thread.

1 Like

ok thx

@AndreasK The requirement is missing. Resolve it by either firing the command feature:install openhab-transport-serial in the karaf console or by installing the serial binding.

Additionally upgrade the MySensors binding to THIS version! It’s no final release but should work out.

I tried feature:install openhab-transport-serial but still get an error see. but I will try the new binding as well

ok great now the MySensors Binding is working again, THX!
Anything I should watch for?

Well, the discovery process has changed. Please let me know If there occures any unexpected bahaviour.

What was the fix then?

Are you planning on updating the binding dependencies to resolve this? This appears to be a workaround for this user.

The new JAR file provided by TimO was the solution.


Apparently not a M6 issue so I moved this to a separate thread

1 Like