Currently running 3.1.0 on my raspberry Pi and I’m having my fair share of troubles with the nanoleaf binding :slight_smile:

I have my nanoleaf shapes up and running on a static IP within the same network as my OH installation. At first everything connected fine and authorized - this was before I created a static IP fir the shapes. One I did that without changing the IP it refuses to authorized anymore. I have even tried to obtain the token manually and enter it, but that didn’t do much either.

This is the error i get in the UI:

Pairing failed. Cannot send authorization request.


I have mentioned it several times in the forum (no offense) that I did major (with capital letters ;-)) improvements in 3.2 within the bundle. I highly recommend to upgrade. Ever since I have no issues at all anymore and I am running quite a number of them here.

Haha thanks - I did read that, but I though reinstalling the binding would upgrade it. I didn’t realise I had to upgrade the entire OH system (Still have a lot to learn) :sweat_smile:

I guesss my issues would be gone as well one it’s done upgrading :wink:

Yes, I believe so. I have upgraded several systems from 2.x to 3.x and 3.1 to 3.2 and usually that should go smoothly (be sure to make a backup first :+1: ). As soon as you are on 3.2 and you still have problems, get back to me and I will help you.

1 Like

That seems to have worked - at least it’s online now :slight_smile:

Thanks man - sorry for my ignorance, it really was an easy fix :blush:

No worries, that’s what I am here for. Enjoy the binding and the nanoleafs and in particular the touch support in the binding.