Neato binding gets status but won't command

neato
Tags: #<Tag:0x00007fe057384ca0>

(Tom) #1

I have recently installed the Neato binding and used the full example (https://www.openhab.org/addons/bindings/neato/) to add items and info to my sitemap.

It all works great in the fact that it will give me the status of my vacuum. When it runs, it will display the battery as it’s going down, tell me the current mode it’s in, etc.

However, if I try to command it to Clean, nothing happens. The log file will only display two lines:

17:54:33.807 [INFO ] [smarthome.event.ItemCommandEvent     ] - Item 'FannDammCommand' received command clean
17:54:33.819 [INFO ] [smarthome.event.ItemStateChangedEvent] - FannDammCommand changed from stop to clean

Any ideas if this is supposed to work? It doesn’t really do me any good to -see- the status, as I can hear and see the thing running! But it would be awesome if I can command it.

Thanks,


(Vincent Regaud) #2

Please post the definition of your item: FannDammCommand


(Alessandro) #3

Maybe the last Neato software update changed the availabe commands (i.e. “clean” become “start”)?

'availableCommands': {'start': True, 'stop': False, 'pause': False, 'resume': False, 'goToBase': False}

(Christoph) #4

I’m having the exact same issue. When the bot get’s started via the app however it reacts to all commands openHab sends it, except “clean”. The wake-up call through openHab doesn’t seem to trigger the bot.

Tried both to send “clean” and “start” but no response:

2018-12-23 14:00:47.216 [ome.event.ItemCommandEvent] - Item 'ShredderCommand' received command clean

2018-12-23 14:02:22.929 [ome.event.ItemCommandEvent] - Item 'ShredderCommand' received command start

Also I’ve noticed the binding often goes offline:
OFFLINE - COMMUNICATION_ERROR java.util.concurrent.ExecutionException: java.net.SocketTimeoutException: Connect Timeout

It get’s back online once I hit save “Configure Neato Binding” in Paper UI without applying any changes. All the state readings from the bot are not affected by online/offline and show correctly. Sorry if that last part is to far off topic.


(Christoph) #5

Did you find a solution? Mine still doesn’t wake up…


(Aaron) #6

@zuernc Did you find a solution


(Christoph) #7

Nope. Nothing new I’m afraid.


(Aaron) #8

Everything else seems too work fine it’s just starting the robot from openhab I just receive a basic4 error


(Aaron) #9

I have also found that IFTTT can remotely start the vaccum

So you could work around it using that method that’s what I plan on doing but you can not use no go lines as far as I can tell this is a shame


(Christoph) #10

Good idea, IFTTT! Shouldn’t the no-go lines work anyway as they are managed by the app+docking station? Please let me know once you’ve tried the setup and how it behaved :wink:


(Aaron) #11

Hi again @zuernc

I have been using it with IFTTT since I posted been working perfectly.

It looks like no go lines are managed by the app

I did speak too neato customer services about it and they said its not possible atm too remotely start the robot with no go lines enabled this is only possible using the app


(Christoph) #12

Thanks for your efforts and for sharing, very interesting!


(Tom) #13

Sorry it has been so long since I originally posted, and for the lack of replying sooner. I haven’t been messing with openHAB since.

But tonight, I seem to have fixed the command to start my Neato cleaning from within openHAB. Just by chance.

I normally use the BasicUI. But to refresh my memory, I first went to the PaperUI. Then I clicked on ‘Configuration’ and then ‘Things’ below that. I found my Neato Vacuum Cleaner there.

I scrolled through the list of channels and noticed that some had different icons. Then ones that were blue with an inner solid white circle seemed to have “linked items” associated with them. The rest did not.

I found the “Send Command” channel didn’t have a link. So just by chance I clicked the blue icon on the left of the command and a “Link Channel” dialog appeared. I left the profile at “default” and in the dropdown list for “Please select the item to link” I scrolled and found ‘Send Command (FannDammCommand)’ and selected it. Ok… That was it.

I then went to my sitemap in the BasicUI, clicked on clean, and…the vacuum started! Whoa!

“Clean Stop Pause Resume” all seem to work now. “Send to dock” is the only thing that doesn’t do anything.

I really have no idea what I just did, but thought I would share it and see how you guys fare.

Tom


(Christoph) #14

Glad you got it working! Mine still won’t wake up and the channel shows as linked to “Send Command”. Strange.


(Aaron) #15

@zuernc

Mine is also the same as yours did you try using IFTTT do you also receive basic4 error when trying too start robot?

@Gunn

What model neato are you using and what firmware is it running


(Christoph) #16

No, haven’t tried IFTTT yet. I’m using the native App and its schedule function.


(Aaron) #17

@zuernc

It looks like there is a fix on github for the basic4 error that stops my openhab setup from launching the bot

@vzorglub

sorry for tagging you out of the blue but i noticed you responded in the post previously do you know how too download the updated .jar file from github i have looked around on there but i’m not familiar with the site yet and cant find any mention of downloading


(Christoph) #18

Great, thanks for sharing!

Just did a feature:list | grep ^openhab but probably due to me still running openHAB 2.3 the Neato binding doesn’t show.

So maybe the issue can be resolved once I upgrade to openHAB 2.4 …still waiting for that weekend :smile:


(Aaron) #19

i’m not sure what it does but i ran the same command and found the neato binding

I’m running that version but looking on github it says the fix is not available in v2.4 but will be added to 2.5 only way is download the .jar and i dont know where too find that either


(Christoph) #20

Hm, I tried building a *.jar from a snapshot once but without success. Supposedly it goes something like this:

jar cvf org.openhab.binding.<<BINDING_NAME>>.jar org.openhab.binding

chmod +x org.openhab.binding.<<BINDING_NAME>>.org

Again, it didn’t work at the time but maybe it points you into the right direction or one of the proper wizards around here knows the way :wink:

feature:list | grep ^openhab shows you the available add-ons for your openHAB distribution, see: Add-ons Through Configuration Files