Need code for Aeon Labs ZW080-A17 Siren

I have the Aeon Labs ZW080-A17 Siren, but I can’t figure out how to make it do anything. Can anyone please provide any working code?

Any luck finding a solution for this?

I would think configuring it as a switch would work, no?

I’ve had no luck, though I’ve not looked much, I had to put this project on hold.

This doesn’t do anything:
Group Siren
Switch siren_1 “Siren1” (gFF) {zwave=“8:0”}

Other things I’ve tried:
;Number siren_11 “sound 1 [%d]” (gFF) {zwave=“8:command=configuration,parameter=0”}
;Number Siren_SetSound “Siren lyd [%d]”

Darn. I tried in parallel virtually identical declarations and not surprisingly had the same results.

Well back to the drawing board.

upgraded to 1.8.1 and it’s still non functional with this code. I can try some other stuff again.

I found this reference
but I have no idea how to use it.

Works fine on my system.

/* Aeon Labs Siren*/
Switch Siren1 “Siren1” (persist) { zwave=“5:command=switch_binary” }

also try" command=configuration,value1=2" etc…

I’m also trying to get this siren (Aeon DSD31) up.
For the moment, I can activate it with the standard sound (switch_binary). :stuck_out_tongue:

But I was thinking to use it for different purposes. Fe sound 5 with lowest level for doorbell chim, sound 2 for fire alert, sound 3 for warning to deactive the alarm mode… Would this be possible, or is only 1 sound possibe? Would be a pitty if it’s like this, these day…

You talk about value1=2 and so, do you’ve got full examples of a (working) config? Since when I put these value, not much change. :blush:

Hi Brononius,

The zwave binding 1.8 and lower only supports siren on/off. Changing of the sounds is not implemented in the bindings.

Damned, no need to look further then. :wink:

But does this mean that if I try openhab2, I would be able to do it?
(I’m strungle a bit if I keep investigating into openhab, or shouldn’t be better start direclty with openhab2).

Really? Why is this? I thought that it’s just a case of setting a configuration parameter?

Everything I tried with all the info from the manufacturer on commands and such resulted in the binding saying its not implemented so I’m really just going on what the binding is telling me. The manual says to use,

{ zwave=“5:command=configuration_set,value1=0” }
{ zwave=“5:command=configuration_set,value1=1” }
{ zwave=“5:command=configuration_set,value1=2” }
{ zwave=“5:command=configuration_set,value1=3” }
{ zwave=“5:command=configuration_set,value1=4” }
{ zwave=“5:command=configuration_set,value1=5” }

To change sound types however they all result in the binding saying it cannot find the mappings etc…

Per the engineering spec manual:
The value 1 (low byte) is used to select the Siren sound:
Default: Value1=1
Value1=0,do not change the current Siren sound.
Value1=1, Siren sound 1 is selected.
Value1=2, Siren sound 2 is selected.
Value1=3, Siren sound 3 is selected.
Value1=4, Siren sound 4 is selected.
Value1=5, Siren sound 5 is selected.

Other values will be ignored.

The value 2 (high byte) is used to adjust the volume:
Default: Value2=3
Value2=0, do not change the current volume.
Value2=1, set the volume to 88 dB.
Value2=2, set the volume to 100 dB.
Value2=3, set the volume to 105 dB.

Other values will be ignored.

I would assume as 2 supports most things now like RGBW etc…

Hmmm - ok, I’m not sure what message that was since I don’t know such a message in the binding :confused:

Maybe there’s an issue using it in rules then, but it is surely working using HABmin to set it manually? (or not?).

It’s just a configuration parameter, so it should be ok from HABmin at least… I’m not sure about the item configuration you’re using (you don’t show what the item type is) - maybe there are issues with config parameters being used in items in some cases…

It’s not currently usable in an item, but I know it works manually - just the same as it should in OH1…

I dont use habmin so not sure. That is the config aeon labs support gave me to use so idk… :wink:

Ok - then you should be able to use your other configuration software then? I’m sure you must use something to configure the network - you just need to change the parameter.

You mean Aeon gave you the item config for openHAB? Wow :slight_smile:. But surely that’s not the whole line…

There must be more on the line than this?

Well yea,

Switch Siren1 “Upper Siren” (gSirens,persist) {zwave=“5:command=configuration_set,value1=2”}

Well, at least one problem is that you can’t use a switch with the configuration converter. You should use a number.

1 Like

In HABmin, you’ll have under Configuration parameter 37, sirenesound and volume. By default, this is 259.
If you change it to fe 33, it start beeping directly with another sound, but after a few seconds, the default value 259 is back in place.
I needed to shutdown the alarm manual with my sitemap/item…

So at first sight, I would say that HABmin is working to play other sounds…