Need for tweak in homeassistant discovery for Tasmota > 12

Tasmota v12.x has dropped the homeassistant mqtt discovery in favor of their own. So discovery messages look like

tasmota/discovery/3494546279D8/config {"ip":"10.0.0.151","dn":"Fountain","fn":["Garden Fountain","",null,null,null,null,null,null],"hn":"garden-fountain","mac":"3494546279D8","md":"Generic","ty":0,"if":0,"ofln":"Offline","onln":"Online","state":["OFF","ON","TOGGLE","HOLD"],"sw":"12.0.2","t":"345picX","ft":"%prefix%/%topic%/","tp":["cmnd","stat","tele"],"rl":[1,2,0,0,0,0,0,0],"swc":[-1,-1,-1,-1,-1,-1,-1,-1],"swn":[null,null,null,null,null,null,null,null],"btn":[0,0,0,0,0,0,0,0],"so":{"4":0,"11":0,"13":0,"17":0,"20":0,"30":0,"68":0,"73":0,"82":0,"114":0,"117":0},"lk":1,"lt_st":1,"sho":[0,0,0,0],"sht":[[0,0,0],[0,0,0],[0,0,0],[0,0,0]],"ver":1}

instead of the old homeassistant/discovery
I’m thinking the easiest place would be to add this option in the mqtt binding but in homeassistant it looks like they went the route of creating a different plugin.

Erik.

Interesting. I wonder what motivated the developer to remove it.

I suggest filing an issue in GitHub. There’s a better chance that the binding developer will see it there.

Good idea… [mqtt] Add Tasmota Discovery · Issue #13217 · openhab/openhab-addons (github.com)

1 Like

It seems that we would need a whole separate (mqtt) binding to support tasmota. @Jorg_Ostertag started working on one but there hasn’t been any updates lately.

I manually set up all my things / items files for Tasmota with the help of my things/items generator, so I am not affected with this change.

Yes … was a little more work than I thought. But a start was done by migrating the old binding to a newer OH-Version.
But currently (and most likely in the near future) other tasks here got much higher priority for me.That’s the reason nothing has been done there.
From what I last remembered …
the binding was able to autodetect switches and Temperature and create channels from that.
This should be a good start …