Need help: "tellstick bridge handler not found" on openhabian, latest snapshot

Tags: #<Tag:0x00007f617a153118> #<Tag:0x00007f617a152fd8> #<Tag:0x00007f617a152e20>

Hi.

Just updated yesterday from 2.3 to latest snapshot and everything worked great apart from the telldus binding.

I see that telldus core is still working, cause I can run tdtool and switch the nexa switches on and off, but Openhab no longer “talk” to telldus core.

Openhab log says: “tellstick bridge handler not found”, so I headed over to the configuration of the Telldus duo, and discovered that the path was changed to a windows path “C:/…”. I tried setting it back to /usr/lib, and restart openhab2, but it still complains. I then tried setting the full path /usr/lib/libtelldus-core.so.2, and restarted openhab again, but it still complains.

Is the binding just broken, or am I pointing the binding to the wrong path? (I cannot remember what it was before upgrade… but it’s been working for a long time)

Regards
Thorbjørn

Updated again last night, still not able to talk to the tellstick duo. I’m using exec in the mean time until I get this fixed, so the tellstick duo and the software does work. It’s the binding or configuration of it that doesn’t work.

Anyone else had this trouble with the tellstick binding on the 2.4 snapshot builds?

Regards Thorbjørn

I uninstalled the binding and reinstalled it to no avail.
Deleted the Thing: TELLSTICK_DUO: Tellstick duo and re added it.
I get these logs:

2018-08-19 21:30:49.427 [INFO ] [ternal.core.TelldusCoreBridgeHandler] - Loading telldus-core from /usr/lib/;/usr/lib/libtelldus-core.so.2
2018-08-19 21:30:49.510 [ERROR] [org.tellstick.device.TellstickSensor] - Tellstick error -3 msg Device not found
2018-08-19 21:30:49.517 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception
java.lang.IllegalArgumentException: Invalid calling convention 63
        at com.sun.jna.Native.createNativeCallback(Native Method) ~[?:?]
        at com.sun.jna.CallbackReference.<init>(CallbackReference.java:263) ~[?:?]
        at com.sun.jna.CallbackReference.getFunctionPointer(CallbackReference.java:449) ~[?:?]
        at com.sun.jna.CallbackReference.getFunctionPointer(CallbackReference.java:426) ~[?:?]
        at com.sun.jna.Function.convertArgument(Function.java:551) ~[?:?]
        at com.sun.jna.Function.invoke(Function.java:338) ~[?:?]
        at com.sun.jna.Library$Handler.invoke(Library.java:244) ~[?:?]
        at com.sun.proxy.$Proxy216.tdRegisterDeviceEvent(Unknown Source) ~[?:?]
        at org.tellstick.device.TellsticEventHandler.setupListeners(TellsticEventHandler.java:123) ~[?:?]
        at org.tellstick.device.TellsticEventHandler.<init>(TellsticEventHandler.java:48) ~[?:?]
        at org.openhab.binding.tellstick.internal.core.TelldusCoreBridgeHandler.setupListeners(TelldusCoreBridgeHandler.java:167) ~[?:?]
        at org.openhab.binding.tellstick.internal.core.TelldusCoreBridgeHandler.lambda$0(TelldusCoreBridgeHandler.java:119) ~[?:?]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
        at java.lang.Thread.run(Thread.java:748) [?:?]

Switched back to the stable 2.3 release, Tellstick Duo works again, so the tellstick binding in 2.4 snapshot is broken.

echo “help” > /dev/null

Same problem here after upgrading from 2.3 to 2.4

Same error for more people when upgrading to 2.4. See issue: https://github.com/openhab/openhab2-addons/issues/3849

Thanks for the replies guys!.. at least I’m not alone about this issue. I began to wonder for a while if I was the only one actually using the tellstick binding. I am a user of the tellstick, trådfri and z-wave binding to control lighting. I love the fact that I can use z-wave sensors to control both nexa, zwave and ikea devices. It makes openhab a very good platform for automation.

I’ve seen there’s been a lot of talk of this bug on github, but there’s very few people replying to my post in this forum, which is a bit disappointing, since this is the official forum for openhab. There seems to be a much more active community going on at github when it comes to bugfixes.

So, I guess this is a question to the devs of openhab… where do you want bugrepots like this posted? Here on the openhab forum, or on github?

Regards
Thorbjørn

Updated tellstick binding jar now available for test, note the NOTEs! :wink:

BR,
/Janne

1 Like