Need help with Fibarro multisensor FGBS 001

Hi everybody,

Hoping to get some help on this matter. I have a new model FGBS 001 connected to my ZWave network. I have the temperature and lux sensors working properly but I cannot get the motion sensor or alarm to work reliably.

I have my items bound to the items with:

Switch Fibsensor_Alarm “Alarm: [%s]” { zwave=“8:command=sensor_alarm,respond_to_basic=true” }

Here’s what the logs show:

:52.013 [Thread-52] DEBUG o.o.b.z.i.p.s.ApplicationCommandMessageClass - NODE 8: Application Command Request (ALIVE:DONE)
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.s.ApplicationCommandMessageClass - NODE 8: Incoming command class CRC_16_ENCAP
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.c.ZWaveCRC16EncapsulationCommandClass - NODE 8: Received CRC 16 Encapsulation Request
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.c.ZWaveCRC16EncapsulationCommandClass - NODE 8: Calling handleApplicationCommandRequest.
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.c.ZWaveAlarmCommandClass - NODE 8: Received Alarm Request
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.c.ZWaveAlarmCommandClass - NODE 8: Alarm report - Value = 0
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.c.ZWaveAlarmCommandClass - NODE 8: Alarm Type = General (0)
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.protocol.ZWaveController - Notifying event listeners: ZWaveAlarmValueEvent
19:59:52.013 [Thread-52] DEBUG o.o.b.z.internal.ZWaveActiveBinding - ZwaveIncomingEvent
19:59:52.013 [Thread-52] DEBUG o.o.b.z.internal.ZWaveActiveBinding - NODE 8: Got a value event from Z-Wave network, endpoint = 0, command class = ALARM, value = 0
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.s.ZWaveCommandProcessor - Sent message Message: class = SendData (0x13), type = Request (0x00), payload = 08 02 84 08
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.s.ZWaveCommandProcessor - Recv message Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 00 08 0D 56 01 71 05 00 00 00 FF 07 08 00 E8 89
19:59:52.013 [Thread-52] DEBUG o.o.b.z.i.p.s.ZWaveCommandProcessor - Checking transaction complete: class=ApplicationCommandHandler, expected=SendData, cancelled=false

I am able to read the events in the debug and see them firing; however, the item is always set to a value of “0” even in the updates. I’ve tried without the “respond_to_basic” and OpenHab throws an error when the zwave event is triggered.

Further, the ‘alarm’ event seems to trigger more reliably than motion detection and I’ve disabled tamper detection / removed association group 2 to reduce false positives on the g-sensor because I live in a condo building. Unfortunately, for both motion sensing and alarm, I run into the same problems though where the item is always set to a value of 0. As a result of the value never changing, my rules don’t trigger properly for when the item receives an update (defeating the whole point of the sensor).

I just want to report that my issues are 1:1 with @anxman as of here.

Contact Fibsensor_Alarm "Alarm: [%s]" { zwave="8:command=sensor_binary" }

indeed , i have one of the newer ones , it should be contact and not switch

I’ve tried CONTACT also using sensor_binary on its own (without respond_to_basic) and I experienced the same problem. The contact never flips from CLOSED to OPEN.

Did you change the various configuration parameters?
It’s very easy to mess up the correct function while playing with it …

Edit: here you will find the manual, set all configs to default and it should work (hopefully):

Edit 2: Stop and let’s start from scratch: WHAT device do you own???
A FGBS 001 is a universal binary sensor and has no motion sensor (unless you attach a separate motion sensor to it) , a FGMS 001 is a multisensor with motion detector.

Sorry, I have an FGMS 001 (error in the title). Also this is not a problem with the configuration – it’s a change in the ‘notification’ and ‘alarm’ classes. Another user was nice enough to create a hack fix to solve this:

I cannot find an FBMS either … and your link points maybe to a private conversation, it’s not accessible.
For reference reasons it is always nice to have the final solution, so when other people encounter the same problem they don’t have to open a new thread :grin:

Long day for me. Sorry.

That’s the one I one. FGMS.