Need Troubleshooting advice for Nortek USB zwave/zigbee controller

I have installed a nortek usb controller and the zwave works fine in openhab2 for inbound and outbound messages. BUT I am using node red to do some of the control with the openhab2 nodes. The commication works fine for openhab2 in nodes but the openhab2 out nodes do not send any communication out to the device. when I try to send and ON or OFF message nothing happens and there is nothing recorded in the openhab logs.

I can control the device in openhab but no outbound commands are passed through from nodered.

I used to run the aeotech zwave controller and it worked fine in node red. but I wanted to add some zigbee devices so I switched to the nortek

Anyone have any suggestions on what I could check to see what might be causing this?

From what you describe, the problem is with the NodeRed configuration. If there is nothing in the openHAB logs that means the messages being sent by NodeRed are not being received by OH. I don’t use NodeRed so can’t help with solving the specific problem but the link between NodeRed and openHAB is where you need to focus your attentions.

I would agree. but how that i’m not sure how that is wired up and what is needed for that to work - it just worked before…


Well, since the problem appears to be outside of OH, you might find the answer on a NodeRed forum. We can usually help once the messages get to OH but if the thing that is supposed to send the message isn’t, there isn’t much you can do about it from the OH side.

I am still trying to get two way communication to work with openhab.

I have flashed the SD card
reinstalled openhabian on Raspberry Pi 3B over wifi.
updated all
installed the aeotec zstick
installed the zwave binding
confirmed two way communication to zwave devices
installed the optional component node red
inbound communication works fine into node red
but zwave outbound commands do not have an effect on the devices.

It appears that the the node-red-contrib-openhab2 communicates to openhab using the rest api.

There seems to be no errors logged in openhab. Node red reports that the command was send successfully.

I have used this exact same configuration with openhab and node-red with great success. But I can’t find what is causing this issue. the only difference is that I installed over eth0 vs wlan0 - could is cause and issue?

Any help diagnosing this would be greatly appreciated.

Status update

I have installed openhabian on 2 different PI 3B+ with different power supplies and SD cards. Used the openhabian-config to install the optional software node red with the included node-red-contrib-openhab2 nodes. all inbound nodes work as well as the monitor node. What I can’t get to work is sending a command to a zwave device to change it’s status. This has always worked in the past. I get no errors in the openhab logs or in the node red console logs. I get no entry that it was even attempted to change.

Any suggestions?