Neo Coolcam NAS-DS01Z does not work with OH 2.5


I have OH 2.5.0~S1762-1 installed with wave binding I have 2 Door/Windows sensors (manufacture Id 0258, ) which I could include successfully and are identified in Paper UI/HABMIN as NAS-DS01Z Door/Window Sensor and - they are both online… but do not work i.e. I cannot make out any zwave activity (except inclusion stuff) in log viewer with regard to these sensors. I also canot see any change in the door contact status when I trigger open or close state. The same sensors do work in OH 2.4. I switched to OH 2.5 snapshot as I have another (NAS-WR01ZE) sensor from the same brand NEO Coolcam which is not recognized in OH 2.4 but OH2.5.
Note: I have tested the Door/Window Sensors with new batteries but and no change.

Any clue?

Properties shown in paperUI:
dbReference 1014

defaultAssociations 1

manufacturerId 0258

manufacturerRef 0100:1027,0200:1027

modelId NAS-WR01ZE

vendor Shenzhen Neo Electronics Co., Ltd

zwave_beaming true

zwave_class_basic BASIC_TYPE_ROUTING_SLAVE

zwave_class_generic GENERIC_TYPE_SWITCH_BINARY


zwave_deviceid 4135

zwave_devicetype 512

zwave_frequent false

zwave_lastheal 2019-11-28T01:59:03Z

zwave_listening true

zwave_manufacturer 600

zwave_neighbours 1,7,8

zwave_nodeid 2

zwave_plus_devicetype NODE_TYPE_ZWAVEPLUS_NODE

zwave_plus_roletype ROLE_TYPE_SLAVE_ALWAYS_ON

zwave_routing true

zwave_secure false

zwave_version 2.21

I was wondering if you have resolved this problem, because one of my NAS-DS01Z behaves exactly the same way as you described it since the update to OH2.5.
Strange thing is, my other two sensor work normal.


no solution yet and I gave it up solving it in openHAB. I switched to ioBroker - there it is working reliable with all different kind of sensors including NAS-DS01Z and also a wallplug of the same brand. So my conclusion is, that there must definitely a zwave bug in openHAB.

If something changes in the zwave device database between one version and another, you may need to delete the Thing and rediscover to pick up new details. (Not exclude/include)


Same for me. Worked fine in previous OH setup (<2.5) but these sensors won’t report anything in 2.5. It is a brand new vanilla setup.
Any help would be greatly appreciated.

Are you sure the devices have been fully discovered? Battery powered devices are especially difficult to keep awake long enough.

There should be an xml file in the zwave folder under userdata. If the file is not there, the device has not been fully discovered.

Only my two NAS-DS01Z do not seem to have been fully discovered, despite having them sitting in close proximity of the controller for several days and a lot of manual interactions with them to wake them up. There is indeed no corresponding xml in the folder. I have tried virtually everything, including resetting them to factory settings and re-include them, to no avail. This had worked flawlessly in my previous OH setup (2.20).

This will sound like a stupid question - but are you sure you have woken it up?

A wakeup is quite specific - it’s not the same as the device sending a report, or something like that. There is normally a very specific button sequence that needs to be performed by the user to send the wakeup notification, and if the binding doesn’t receive that notification, then it will not (ie can not) talk to the device.

I would suggest to get a debug log if you’re unsure - see the binding doc for information on how to set this up.

I have had a few Coolcam devices that needed to be factory reset before they would include properly.

I would exclude from the network, delete the Thing, if it exists.
Factory Reset the device
Include into the network
Discover the Thing, keeping the device awake until fully discovered.

But this device is already included. It should be communicating and probably a log is required. Once it’s included, the binding needs to interview the device, and that’s when the XML is generated. The XML is an internal file used by the binding to hold information about the device between binding restarts and if it’s not being produced, then I’d really suggest getting a log - otherwise we can only speculate.


I have similar problem. My Window sensor was added to the network successfully, but I don’t get any notifications from it. I have created items for for battery and door opening, but it does nothing. Battery status is always NaN and door ‘-’

Have you followed the good advice in this thread?
How do you know the sensor was added successfully? Did the binding create an xml file?

As Chris said, unfiltered debug logs are very helpful. The binding documentation tells you how to collect them.

I got the same problem.
A new Neo sensor not working with version 2.5. I have an old one that exclude and work at version 2.4. the new exclude and recognize but I can get any notification fro the device, either close/open or battery level
I try all the advice here but seems no help.

Any other advice?

If the advice in this thread did not help, you do NOT have the same problem. To avoid confusion, pleas open a new thread.

I finally was able to fix it… :smiley: Just add the Controller to the “1: Lifeline” Association Groups via HABmin and wake up the Sensor manually. Device (neo-coolcam-door-window-sensor-z-wave-plus; Also known as: NAS-DS01Z Door/Window Sensor ) was working fine (without the manual Lifeline association) with OH 2.4.x but failed with OH 2.5.x and is still broken with latest 2.5.12-1. No idea about 3.x

More details about the manual Association to Lifeline:

  • Add Battery to Sensor
  • Put OH in ZWAVE Inclusion Mode
  • Press Button inside the sensor 3x times within a 2 secs or so → The LED should blink a few times
  • You should see a new ZWAVE Device, Add it with Name like ZWSwitch01

Above steps only if not already added

  • Go to HABmin-> Configuration → Things → → Association Groups
  • Add in section/field “1: Lifeline” the Entry “Controller”
  • Click on Save; You will see something like “in Progress”
  • Wake up Sensor by pressing three times the button inside the Sensor
  • Refresh the HABmin page – “In Progress” shall disappear
    I now receiving updates for the channels:
    sensor_binary + sensor_door +battery-level
    but seems like not for alarm_tamper but anyway don’t undersands this channel but also dont miss it.

My Device info from PaperUI (same for my about 2 years old one and the brand new one):
|dbReference |400|
|manufacturerId |0258|
|manufacturerRef |0003:0082,0003:1082,0003:2082,0003:3082,0003:4082,0003:6082|
|modelId |NAS-DS01Z|
|vendor |Shenzhen Neo Electronics Co., Ltd|

See OpenSmartHouse Z-Wave Device Database

@chris Any idea whats wrong if no updates are received from the Sensor unless manually adding Controller to “1: Lifeline” Association Group ?


PS: I know quite old topic but saw similiar questions in other discussions as well… hope will help others as well.

That database entry shows the controller already assigned to Group 1.
Did you delete the device Thing from openHAB and re-add it when you moved from 2.4? That was recommended when upgrading to get the latest binding settings.

I have two devices:
Old Device: was migrated from OH2.4 to OH2.5 and not sure anymore but maybe not deleted&re-added
New Device: I only bought this recently and added to 2.5.12-1 initially (was never attached before)

Also the new device was not autom. assigned to Group 1

The devices themselves do not by default get assigned to a group. Other than the controller Lifeline the groups are designed for controlling devices separate from OH. You could have a switch control a light using groups without OH.