Neo Coolcam Water sensor not associating

Hi all,

I recently added the Neo Coolcam water sensor to my Z-wave setup:

Inclusion to the network works fine, and the device/manufacturer get detected as expected. When I try to associate the Device status group, I get an error:


After that, the association field is emptied out again. What could this indicate? How do I dig deeper?

Some more troubleshooting info:

  • tried restarting OpenHAB
  • tried excluding and including the thing
  • same error occurd when doing this through PaperUI
  • seems now like this error occurs for all of my Z-Wave items, when trying to update any of the settings

Looks like I might be in the same boat as these guys and a couple of other threads: BUG: Update Thing Configuration Parameters yields ERROR: 500 - Internal Server Error on PaperUI

Only, most of them note the error doesn’t appear inside HABAdmin - here it does.

@chris, if it could be interesting for you, I’d be available to do an interactive debug session?

I’ve updated a PR at ESH that should improve the debugging and hopefully this will be merged very soon. There’s also another PR I’ve just merged into the binding which might help…