Neo Z-wave Light Switch EU-2 stopped working with Z-Wave - any ideas?

Hi, I have a problem with my Z-wave Light Switch EU-2.

I’ve been using it for around 2 years, and a week ago it has suddenly lost connection to the controller, being shown as dead and not communicating at all.

Local operation using sensor buttons is working good.

I’ve tried to exclude it from the network by following instructions from the manual (switching controller to exclude mode, then triple touch the left button), but no luck.

Then I’ve tried to hard reset the switch by holding the left button for 10 seconds. After that both buttons are constantly showing red light, and switch operation (even local) is completely blocked until I cut off the power.

After I put the power on again, the switch quickly blinks with red light 5 times (as if it’s already in the network), then I try to include it into the network again by triple touching the left button, the switch blinks with red light 5 times, but is still not communicating with controller.

I’ve already written to Neo Support, but they are ignoring me. Maybe someone from this community has come across with the issue and can help me?