NeoCoolcam Zwave devices not reporting data

Hello all,
I recently bought two NeoCoolcam door/window sensors and I initially included just one to the Zwave network and although that it is shows as online I never got to read data out of it in the sitemap. I only see a dash for both the status of the door and the status of the battery.

Initially I thought that it was specific to the one sensor and I included the other one as well and it does the same.

Now that I think of it though I also have couple of Fibaro dimmers and after upgrading to the new binding they don’t reflect the status of the lights they are connected to. At least not always.

Has anybody else seen the same behaviour?


I would appreciate any help on the matter.
I also own NeoCoolcam PIR sensors and LUX data are not reported. What am I doing wrong ?

No. Make sure you are using the sensor_door channel. Also make sure you have the association group set correctly to your controller.

Which one, there are three

Which openHAB version are you using? Which zwave binding version are you using? Please be a lot more specific in your questions go get any help.

Hello @sihui,
thank you very much for replying.
My PIR sensor is the PD03Z with 3.80 firmware.

My door sensors are NAS-DS01Z of Type/ID 0003:1082 and this is how I have them listed in my items file.

Contact Door_Sensor “Store room sensor [%s]” (gChart) {channel=“zwave:device:zwaveController:node17:sensor_door”}

I set the controller in Assosiation Group 1 but it is never saved and always empty as the rest of the groups. What is to be done here?

Excuse my ignorance but I am kind of novice user and do not know what exactly is to be said to provide all the info for someone to help. Again, excuse me and thanks for replying!

I have quite some NeoCoolcam battery devices and a common issue that most of the devices had: empty batteries! I was able to include them, but then they just stopped working (fresh out of the box). I was ready to throw them out of the window until I changed the battery for one of them - and they worked.

1 Like

Hi @Chrishab ,
interesting experience. Were you able to see the device LED flashing whenever you would move the magnet to simulate OPEN/CLOSE action ? I don’t currently have any spare batteries and the one I took out from the PIR does not fit, it is a different type.

I asked for your openHAB and zwave version, you did not answer. We cannot help you without information.
There is a difference between version 2.4 and 2.5, please search the forum to find out.

Yes, the LED was flashing, also when waking up the device. Nothing else happened though. Happened to me with a Neo PIR and the water sensor.

After replacing the battery the worked fine (you might need to exclude and include again)