NeoHub binding: Error connecting to my neoHub 2nd generation

Hi All,

I’m having trouble connecting the NeoHub binding to my 2nd generation hub. I have searched the forum for answers and I’ve tried quite a few different methods. I’m hoping someone can help me…

Installation details:

  • Raspberry Pi 4
  • neoHub (2nd generation)
  • Openhabian (openHAB3)
  • Openhab stable 3.1
  • Tried the standard binding and also the snapshot below:

After installing either version of the binding the hub is auto-discovered but when I add it via the UI I get errors…

I’ve also tried adding the bridge via a .things file:

Bridge neohub:neohub:neohub "Heatmiser NeoHub" [ hostName="192.168.1.127", portNumber=4242, pollingInterval=60, socketTimeout=5, preferLegacyApi=false ]

This is what is shown in my logs:
2021-12-12 07_28_49-tail -f _var_log_openhab_openhab.log _var_log_openhab_events.log

I’ve tried setting “Prefer Legacy API” to true but that does not work either.

Any help would be really appreciated, thanks very much!

For those that arrive here due to the same issue, I found a way. First you have to open the Heatmiser App and enable “Legacy API” which is found in settings/api access/

Then set the neohub thing to “Prefer Legacy API”

I missed your post. And I am glad you solved it, by forcing legacy API. But I would like to figure out why it does not work in your system using the new API. So would you be willing to log:set TRACE on the binding and force non legacy API (for a few minutes) and post the salient data?