Nest Binding Away/Home Behavior Has Changed Recently

Tags: #<Tag:0x00007f6173b541a0>

@wborn

I’m not sure when this changed, but it happened after November 25, 2018 (last time I used this capability).

It used to be that when one changed the Structure’s Away/Home state using the binding, the setting would be reflected on the Nest side. Now, if I change this, it only changes the thermostat’s (the only Nest device I have) mode to/from Eco. This behavior is as before (mode change to/from Eco), but now the Structure state is not being set.

Any guidance on tracing what’s happened?

Regards.

Mike

That’s odd because I’ve been setting my structure home/away without any issues almost every day with openHAB 2.3.0/2.4.0.

You could enable debug logging on the bridge to see if it makes proper HTTP requests when handling commands:

log:set debug org.openhab.binding.nest.internal.handler.NestBridgeHandler

You should then see what data it is sending to Nest and what the response is (see code).

Also make sure to use upper case characters in the HOME and AWAY commands. The 1.x binding uses lower case values.

Thanks Wouter. I’ll turn on DEBUG to see what’s going on.

BTW:
OH2: 2.4.0~20181105174706-1 (Build #1413)
Nest Binding: 2.4.0.201811051653

I’m holding off on updating to the 2.4 stable release because I’m a bit worried about it grabbing the new MQTT binding which I’m not ready to switch over to yet :wink:

Well, this is frustrating…

I had tried restarting OH and also rebooting the server altogether. No effect.

This morning I tried setting the Structure state (using PaperUI) and it behaved as I described in my initial post last night.

I set the log level to DEBUG… and the Structure changed state properly (both AWAY and HOME). Arrgh! I set the log level back to INFO… and it still works!

So, for now, I can no longer reproduce it. I’ll have to wait until my rule runs again to see if it happens again. I’m going to leave it logging at DEBUG to try to trap the issue.

Mike

P.S. My rule does use upper case “HOME” & “AWAY”

There’s nothing to worry about. :slight_smile: Just make sure you enable legacy bindings and you can still use the mqtt1 binding without having to immediately migrate to the new binding. See also: MQTT Binding 2.4 - what changed? not working anymore

Thanks Wouter, I might give updating OH it a try. I’ve been weighing the risk of all my MQTT stuff becoming unstable (I do have legacy & mqtt1 set in my addons.cfg) vs. dealing some of the current pains (e.g., the Cloud Connector Offline manual reconnect).