Nest binding - No items showing in Inbox after setting up SDM account

I have set up the Nest SDM account per documentation, and shows online as well. However, I am not seeing any of my items (2 Thermostats and 1 Doorbell) in my Inbox. Binding version shows 3.1 and I had recently migrated my account to Google. Unfortunately there are no troubleshooting steps that is available within the Nest binding’s documentation.

What am I missing?

I did find a partial solution by manually scanning under Add Thing > Nest Binding > Scan. It showed one doorbell (Nest Hello) but only one (Nest Thermostat E) of the two thermostats that I have under my account. The one that didn’t show was a Nest Thermostat 3rd Gen.

Any pointers would be appreciated.

Just a try,

It helped me to move my devices into a random different room on my nest account and then start discovery in OH again. They showed up in my inbox.


I did remember someone mentioning this in one of the other threads. I did try that but to no avail, but when I attempted the manual scan, at least 2 out of 3 showed up immediately.

The only thing I could think of is to remove the offending thermostat out of the account completely and re adding it. I’m holding off from doing that simply because it will require the Learning Thermostat to start the “learning” all over again.

What is the log setting do a detailed trace on the binding and see what’s happening via the logs?

I finally solved it.

First I tried removing all the things including the SDM account thing. This time only one of the three items showed while scanning!!! So ended up deleting all the things, uninstall the binding, restart OH, installed the Nest binding, added the SDM account, and finally did a Add Thing > Scan against the Nest binding. Viola!!! All the items were showing up to be added!