NEST with " Unable to get state from data model"

Hi There,

i just bought three smoke detectors and love them. Now i like to intergrate them into openhab 2.0 stable to create a rule that switches alle lights on if there is an alarm.

Installed binding, created product, set permissions, got id, secret and pin, created a simple item from the documentation (name of smoke sensor) and the the above mentioned error.

Then i tried to creat a new product updated the values and still the same problem. As afr as i understand the only configuration needed are the id, secret and pin to log in -> This works, because with wrong values i get a not authorized error.

Ans in my item i need to set the name of the device

String   NestSmoke_name "Name [%s]" (gHallwaySmokeSensor) {nest="<[smoke_co_alarms(Eingangsbereich).name]"}

So has anybody some hints for me how to solve the problem.


Did you also check the items mentioned in this discussion?:

Yes check it and renamed the whole Structure to Home, even if i did not use it

You can also increase the log level of the Nest binding on the console for more clues. It will show you what URL is called and the exact JSON response:

log:set trace org.openhab.binding.nest
14:34:37.579 [TRACE] [ab.binding.nest.internal.NestBinding] - Querying Nest API
14:34:37.579 [TRACE] [st.internal.messages.AbstractRequest] - About to execute ''

You can call the same URL as the binding is using in your browser to get the response. And format it with your favorite JSON formatter. The response should contain a smoke_co_alarms array and the items in it should have familiar names.

Afterwards you can revert the loglevel back to info.

The log trace was the right hint. If have now found that the binding uses the english value and not the german ones i see on the Nest webpage

So “Eingangsbereich” is “Entryway” and with Entryway i will get the values


1 Like