Netatmo Binding MAC Input Validation

Dear community,

I am new to OpenHAB and trying to configure my first ‘Thing’ to a Netatmo in-house air quality station (Main indoor station). The problem is that I cannot enter the ID of the station, which is required to be entered in a format of MAC address. The input field validation does not accept the value although it is a valid MAC address format.

I am entering the value:

Tried also the low-case:


The error message is:
Input should satisfy expression
\p{XDigit}{2}:\p{xDigit} {2}:\p{XDigit}{2}:\p{XDigit}{2}:\p{XDigit}{2}:\p{XDigit}{2}

I am using binding-netatmo - 2.1.0, freshly installed from the add-on bindings.

I am using openHAB 2.1.0 - release build -

The problem is repeatable in any modern browser (tried chrome, firefox and iexplorer).

I also tried to find out how to define device manually, but I failed.

I created the file /etc/openhab2/things/netatmo.thing with the following content:

Bridge netatmo:netatmoapi:home [ clientId="xx", clientSecret="xx", username = "yxxx", password = "yyy", readStation=true, readHealthyHomeCoach=true, readThermostat=false] {
    Thing NAMain    inside  [ equipmentId="70:ee:50:26:30:ea", [refreshInterval=60000] ]

But it was not picket up by openhab. At least the new Thing didn’t appear in the “configuration” -> “Things”.

The only thing I managed to do is to create a Netatmo API Thing, which has an “online” status.

Any ideas how I can continue troubleshooting this situation?

Thank you in advance for your tips.

Kind regards,

I had the same issue. I deleted the Netatmo Things ( NOT THE API, just inside and outside items ) and then did a search in the inbox again, the Netatmo where showing in the inbox, I added again things to paper ui and the devices where back ONLINE, working again without further issue and with the MAC addresses back in place.

Hey Anton,

This issue has been solved some days ago. Yesterday there was a new stable release OH2.2.0. You can upgrade to that version and after that you should be able to change the mac address without any problems. Please be aware that the equipmentId has been replaced by id in the latest version of the Netatmo binding.

That’s it! Thank you, guys!