Netatmo not showing battery-status for some devices

I’m having the Netatmo-bundle installed, at most of the data is working fine.
Only problem is battery-status for my wind- and rain-gauge. No data is received/showed. My outdoor module is working fine.
I tried to enable debug log-level for the bundle, but it didn’t show any problem.

Any idea how to solve this problem?


This is still a problem for me - anybody having any suggestions on what’s happening?

One thing I just noticed. If I’m changing the item from a “Number” to a “String”, then I get an error in the log.

23:21:12.650 [INFO ] [del.core.internal.ModelRepositoryImpl] - Refreshing model 'netatmo.items'
23:21:12.654 [INFO ] [smarthome.event.ItemStateChangedEvent] - NetAtmo_Rain_BatteryLevel changed from NULL to UNDEF
23:21:12.655 [ERROR] [ipse.smarthome.core.items.GenericItem] - Tried to set invalid state 74.00 (DecimalType) on item NetAtmo_Rain_BatteryLevel of type StringItem, ignoring it
23:21:12.656 [INFO ] [smarthome.event.ItemUpdatedEvent     ] - Item 'NetAtmo_Rain_BatteryLevel' has been updated.

If I’m then changing it back from “String” to “Number”, then then item shortly having the value…

23:21:18.614 [INFO ] [del.core.internal.ModelRepositoryImpl] - Refreshing model 'netatmo.items'
23:21:18.619 [INFO ] [smarthome.event.ItemStateChangedEvent] - NetAtmo_Rain_BatteryLevel changed from NULL to UNDEF
23:21:18.621 [INFO ] [smarthome.event.ItemStateChangedEvent] - NetAtmo_Rain_BatteryLevel changed from UNDEF to 74.00
23:21:18.624 [INFO ] [smarthome.event.ItemUpdatedEvent     ] - Item 'NetAtmo_Rain_BatteryLevel' has been updated.

Any clue why this is happening???