Netatmo values not populating

I am trying OpenHab for the first time and running into some challenges. I’ve successfully gotten my NetAtmo device basically configured, with oauth2 refresh token setup, etc., as evinced by the following from the logs:

2015-12-22 17:11:46.395 [DEBUG] [.b.n.internal.NetatmoActivator] - Netatmo binding has been started.
2015-12-22 17:11:46.403 [DEBUG] [i.internal.GenericItemProvider] - Start processing binding configuration of Item 'bedroom_co2 (Type=NumberItem, State=Uninitialized)' with 'NetatmoGenericBindingProvider' reader.
2015-12-22 17:11:46.405 [DEBUG] [.NetatmoGenericBindingProvider] - Processing binding configuration: '70:ee:50:xx:xx:xx#Co2'
2015-12-22 17:11:46.411 [DEBUG] [.NetatmoGenericBindingProvider] - Adding binding: NetatmoBindingConfig [userid=null, deviceId=70:ee:50:xx:xx:xx, moduleId=null, measure=CO2]

I added a basic items entry:

Group Bedroom
Number bedroom_co2   "Carbon dioxide [%d ppm]" (Bedroom) {netatmo="70:ee:50:xx:xx:xx#Co2"}

I then tried to display it, either as a standalone item, or undera Bedroom group:

sitemap home label="Main Menu"

Frame {
  Group item=Bedroom  label="Bedroom"      icon="bedroom"
  Text item=bedroom_co2

However, I never get any readings (always “- ppm”, whether at the top level menu or the Bedroom submenu).

I searched around the forums here, turned up logging level, etc., but “etatmo” only appears in the logs as shown at the top of this post (nowhere else i.e. no exceptions in logs etc.) :confused:

Any ideas or suggestions would be most appreciated!

Solved it myself - the problem is adding units (which are legal in 1.8 apparently) causes 1.7.1 to silently fail. Once I commented the following out things resumed working correctly:


You can grab the 1.8 binding at if you want to use the new 1.8 functionality.