Network binding error Cannot run program "arping" (in directory ".")

I use the network binding for the first time on Windows10

In the PaperUI I configured “Listen to DHCP reqeusts” to OFF and deleted arpping in arp ping tool path, because this tool does not exist on Windows. I just want to use the java ping.

But in log I got:

2018-01-13 14:48:43.385 [WARN ] [] - Execution failed (Exit value: -559038737. Caused by Cannot run program "arping" (in directory "."): CreateProcess error=2, Das System kann die angegebene Datei nicht finden)
2018-01-13 14:48:43.416 [INFO ] [ternal.dhcp.DHCPPacketListenerServer] - DHCP request packet listener online

It looks like listen to dhcp is on? and OH is searign for arpping?

All is working but I want to get rid of this error messages. Any idea?

1 Like

You need to install arpping:

Yes, I know. But I do not want to use it. I want to use the “java integrated ping functionality” by setting “Allow system ping” to ON.

From the network binding KB:
Allows or disallows to use system pings next to the java integrated ping functionality. On windows the system ping works more reliable most of the time.

But it looks like the binding is searching for the arpping tool even if I do not need it.


I don’t know if there is away to tell it to not look for it. You have a solid argument for filing an issue requesting this as an addition if there isn’t.

For now, it seems as it is using system ping like you want, might just have to put the arpping binary in the path to silence the error.

So I will ignore the error.

Other question

DHCP request packet listener online

But it is configured as OFF? Is this an error too?

Maybe I will ignore it too. Not needed too.

That’s not an error, that’s a feature :slight_smile:

I also do not know if you can turn that off. I don’t think it will hurt anything. It just keeps an eye on DHCP packets on the subnet. It allows it to basically eavesdrop on other devices doing DHCP handshakes which allows OH to know sooner when a monitored device comes online.

OK, so I will ignore both. thanks.

I come back to this post.

Yesterday it is working, today not.

The device is powered off but the binding tells me it is on and gets “latency” and “lastseen” values? Very strange.

This sentence of the documentation is a little bit confusing:
Create a file in your openHAB/etc directory

On my OH2 on windows there is no openHAB/etc, only openHAB/userdata/etc and openHAB/runtime/etc

Which on is the right one. And is this config used in parallel to the paperui-config of teh binding?

I assume it means in your service folder. For apt installs that would be /etc/openhab2/service/network.cfg. I’m not certain for windows… based on the docs looks like maybe here?: C:\openHAB2\userdata\etc

I don’t have a network.cfg file and it works fine for me but I suspect you only need the file if you are going to make the system pings change like you want. I would create a file named network.cfg in that location and put “allowSystemPings=true” in there.

Others may way in on this as I don’t have first hand experience with running in windows OR using system ping.

I experience exactly the same. My OpenHAB 2.2.0 is running on a Windows OS box too.

Basicly I don’t mind, if the binding uses arping or not (at least I think), my intension is to use the binding for iPhone presence detection. However the documentation is mentioning ARP pings in connection with iPhone and iPad devices, and I wonder, if it would make the function more reliable using arping!? Therefore I have downloaded arping for Windows, and placed the exe file in my C:/OpenHAB2 folder. I’m not sure that’s how the documentation describes it to be:

Make sure the tool is available in $PATH (%PATH% respectively on Windows) or in the same path as the openHAB executable.

I guess not, because doing that still generates the "…Cannot run program “arping” (in directory “.”)…) warning.

From the PaperUI it’s possible to configure the ARP ping tool path, but doing so doesn’t change anything, still generates the warn.

Likewise I have tried to configure the ARP ping tool path by creating a file, and place it in C:\openHAB2\userdata\etc. Same result, still generates the warn.

@HomeAutomation, have you figured something out, solving your problem?

Best regards Ole


No, I did not find any solution with this binding, i moved to fritzbox tr064 binding, and this works fine.

Thankyou for replying.

Have had a look on the Fritzbox TR064 binding. I’m in doubt if this could solve the problem for me too, since my home network is based on ZyXEL router and D-Link access points. Are you using Fritzbox products for your home network?

sorry, I did forgot to mention, I use a fritzbox as router.

Hi everyone,

i have the same error Message on my opneHAB 2.2 installation. openHAB runs on a qnap homenas and yes, i have installed the arping.

arping seems to be in the path variable, so i can use arping manually when i am connected to the qnap.

i tried to set the path variable at the binding, but i still get this error message in the log:

Execution failed (Exit value: -559038737. Caused by Cannot run program “arping” (in directory “.”): error=2, No such file or directory)

Anybody knows a solution for my problem?

1 Like