(Network Binding) Getting WARN when thing is not in network

I created a new thing for the network binding (a phone in the WLAN) while it was ONLINE and linked an Item to the Online channel. That works, however if the device is not in the WLAN I get the following WARN message:

18:27:10.289 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate update ‘OFF’ for item ‘PhoneXY_WLAN’ to handler for channel ‘network:device:network:device:xxx_xxx_xxx_53:online’, because no thing with the UID ‘network:device:network:device:xxx_xxx_xxx_53’ could be found.

The funny thing about that is, I have two other phones using the same SetUp, for which I don’t get those messages???

I’m using OH2 Release build
Network binding 2.0.0

Are you really sure?
It looks like a misconfig:

should be something like

Double check your thing config …

Ups, I don’t realise that “double-naming”. This thing isn’t listed in PaperUI, I’ll check on console.

Should be in there named as “Netzwerkgerät”.

Using smarthome:list I only get things like

network:device:xxx_xxx_xxx_41 (Type=Thing, Status=ONLINE, Label=Phone_WLAN, Bridge=null)

nothing with “Netzwerkgerät” nor “network:device:network:device:”

Okay, either your “Thing” is defined through PaperUI or through a things file. Check both options and see were you have made probably a typo.

Example from my system:

network:device:phone_sigi [ hostname="192.168.x.xx", port="0", retry="1", timeout="5000", refresh_interval="10000", use_system_ping="false" ]

Thanks for the reply and sorry for the late reply (some real world business).
I looked at all your suggested location and found nothing. I found it in:


In there was the “network:device:network:device:xxx_xxx_xxx_53”, I deleted it and now it is working as expected.

1 Like