Network binding not seeing anything

I’m brand new to openHab. I just copied the openhab-2.1.0 folder to my home dir and started ./ from that dir in a terminal. I chose standard install and then installed the network binder. The first time I did this I saw every device on my network. I then created a new install on an new/similar machine (all same specs) and inbox found nothing. I tried a new install on my first machine and now it can’t see devices either. I was able to see computers, routers, smart devices, etc. All my ip’s were showing. Perhaps I did a step at first that enabled something that I missed now?

UPDATE: Ok, so I figured out what but not why. I added a z-wave binding and then plugged my z-stick in and tried an inbox on the z-wave and found nothing (only a smartThings hub out there for the moment) then went and did another network scan and everything was showing. I’m not sure why the z-wave made any difference.

A LITTLE MORE INFO: I didn’t realize the first time, but having looked more closely, the list of “network devices” is actually the entire network subnet 1-254. I don’t imagine this should be the case. Any ideas why this is happening?

  • Platform information:
    • Hardware: x86 Quad core/16gb/1tb hd
    • OS: MacOs High Sierra
    • Java Runtime Environment: Oracle 1.8.0_121
    • openHAB version: 2.1.0
  • Issue of the topic: Inbox search after new install and only install Network Binding
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences: