Network Binding with Windows 10

Hi openHAB Team,

Sorry, but I didn’t find a similar case in the community and I have got a simple question :slight_smile:
Why does the openHab indicator for my Windows 10 Notebook shows “offline”?

I have got 3 things and 2 of them are working properly (for the router and the printer).
If I send a ping from another device to the Windows 10 Notebook I will get a response.

So I think that it might be the openHab conf.

Thing network:pingdevice:cmNotebook “Notebook Christian” [ hostname=“xx”, macAddress=“xx” ]
Thing network:pingdevice:Ping_FritzBox “Ping_FritzBox” [ hostname=“xx”, macAddress=“xx” ]
Thing network:pingdevice:Ping_XeroxPrinter “Ping_XeroxPrinter” [ hostname=“xx”, macAddress=“xx” ]

Switch cmNotebook “Notebook Christian” { channel=“network:pingdevice:cmNotebook:online”}
Switch Ping_FritzBox “Ping FritzBox [%s]” { channel=“network:pingdevice:Ping_FritzBox:online”}
Switch Ping_XeroxPrinter “Ping XeroxPrinter [%s]” { channel=“network:pingdevice:Ping_XeroxPrinter:online”}

sitemap demo label=“Main Menu”
Frame label=“Netzwerk” {
Text item=cmNotebook label=“CM Notebook [%s]”
Text item=Ping_FritzBox label=“Ping_FritzBox [%s]”
Text item=Ping_XeroxPrinter label=“Xerox [%s]”

It shows “offline” every time, but I am working with the device…

Windows firewall issue?

If I send a ping from another device to the Windows 10 Notebook I will get a response.
I tried from 2 devices and it worked.

as far as I remember the network binding uses different methods to detect if a device is online.
Thus even in case the device is reachable via pings it could mean that an other method is used to detect if the device is online and that method might not work.
This is why I think the question about the firewall still might be valid.

In my environment I am using

use_system_ping="true", dhcplisten="true"

in my thing definition.

An other possible cause could be that the hostname that is part of the thing definition is misspelled or DNS does not work with this hostname ( sorry, I do not know if you used IP or hostname in your test to ping the windows machine ).

1 Like

The solution is to restart openHab!!
Thanks for your help!

Sorry, I forgot the network.cfg.
So here it is, may it help anybody:

Do you have arping running on Windows 10? What do I need to setup for this?

No, I haven’t.
And now everything works fine…

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.