Network issue with Novelan binding

Hi there,
I have installed openHAB2 on a RPi3 the other day and I want to read data from my Novelan Heatpump.
I installed the Novelan/Luxtronic binding via PaperUI but it cannot connect to the heatpump due to a network error:


2018-03-28 18:27:07.663 [WARN ] [lanheatpump.internal.HeatPumpBinding] - couldn't establish network connection [host '']

Ping is working, also from RPI3, Novelan firmware version is v 1.60, also the NovelanApp works.
Configuration should be fine?

# IP address of the Novelan (Siemens) Heatpump to connect to (required)

# port number of the Novelan (Siemens) Heatpump to connect to (optional, defaults to 8888)

# refresh interval in milliseconds (optional, defaults to 60000)

In the log I find:

2018-03-28 17:42:50.201 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at
2018-03-28 17:42:50.253 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at
2018-03-28 17:42:57.483 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model ‘NovelanWP.items’
2018-03-28 17:42:58.161 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model ‘influxdb.persist’
2018-03-28 17:43:00.930 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2018-03-28 17:43:06.206 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
2018-03-28 17:43:06.872 [INFO ] [assic.internal.servlet.WebAppServlet] - Started Classic UI at /classicui/app
2018-03-28 17:43:06.961 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2018-03-28 17:43:07.119 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2018-03-28 17:43:07.262 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2018-03-28 17:43:07.409 [INFO ] [b.core.service.AbstractActiveService] - Heatpump Refresh Service has been started
2018-03-28 17:43:07.457 [WARN ] [lanheatpump.internal.HeatPumpBinding] - couldn’t establish network connection [host ‘’]

Let me know if you need more info, I am a newbee and no programmer.

I am also running successfully Grafana and influxDB on the RPi3 for a couple of months now, this should not be an issue? I have restarted the openhab2.service several times but the error keeps coming back.

Would be great if someone has an idea what I am doing wrong or how I can get more info about that error?


According to:

“port number of the heat pump to connect to Please be aware that from firmware version 1.73, Alpha Innotec has changed the port to 8889”

Try port 8889 in the cfg file

PS, please use code fences to show codes, logs… It is much easier to read!

My firmware version is 1.6, I tried 8889 already, does unfortunately not work.

Thanks for the hint with the code fences! I will check it out

ok, code fences, done;-)
anyone else has a novelan/luxtronig 1.60 firmwareversion where everything is fine?

so here is what i have done so far.
I conencted via telnet to the heatpump and checked with netstat if there is something I can make sense of, i could not :stuck_out_tongue:
After that I forced the heatpump control unit to reboot and I rebooted the RPi3, no change, still the same network error.
I asked Novelan support for help and they recommended me to update my heatpump firmware to the latest version (v1.8.1). So I did. In case you try to do the same, safe yourself some time and format your USB-Stick with FAT16 before…
So, now the network connect error in the log is gone, on top of that I can now also access the the heatpump via browser, that was not possible before :grin:
However there are intersting new line items to be found, that I can make no sense of:

2018-04-08 12:59:29.197 [INFO ] [lanheatpump.internal.HeatPumpBinding] - found new value for reverse engineering !!!! No idea what the heatpump will do in state 4.
2018-04-08 12:59:29.201 [INFO ] [lanheatpump.internal.HeatPumpBinding] - found new value for reverse engineering !!!! No idea what the heatpump will do in state 15.

Anybody an idea how I can stop these entries? They seem to be not critical, but they are written every minute and I am afraid they will eat up my diskspace…

Now I can continue my journey to transfer the heatpump data into my influxdb and visualize with Grafana :rofl: