Networking in docker problem

Hi, I have just setup OH2 few days ago. I run it in docker container.
First, I started the container manually by ‘docker run …’ as is instructed on dockerhub. I Installed Kodi and SamsungTV plugins and added them as a thing and bind all the items. All data was reported correctly, I could see what channel Iam on and so on, but I could not control anything.

I went to logs and found some network errors:
I do not have the exact java exception now, but the main point there was "Socket not initialized"
[ERROR] [rnal.service.RemoteControllerService] - Could not send command to device on org.openhab.binding.samsungtv.internal.protocol.RemoteControllerException: Connection failed

I then created a system file as is instructed here. I, on purpuse let the container started under the root user. Since then, Kodi works as expected, but I still get errors for the Samsung TVs. I really dont know where the problem is, but my first guess would be something docker related.

Can someone help me with this problem?
Any help much appreaciated!

My OS is Ubuntu 16.04 with Docker version 1.13.1, build 092cba3