New 433 Mhz CUL and Intertechno Binding

any kind of chat in here? englisch gets on my nerves :slight_smile:

Use private messages.

I´ve done it with this script:

But i´m getting strings back which are very short:

e.g. 404015F2 for on.

I´m getting back this from the python script:

The id of your remote control is:

The group flag is:
Traceback (most recent call last):
File “”, line 37, in
IndexError: string index out of range

@opus @dartrax

any solution?

The correct command with “is” would be using your settings from post #1 switching ON.


1 Like

From what I undetstood, there was no need to change any Config of the RasPI3, it was solved by using the correct codes for the Intertechno PA1500 plugs and the correct usage of a standard switch item.


  1. Insert CUL in USB Port

  2. Be sure to have Openhabian installed - Rasberian gives back a device error concerning mount of USB CUL:
    (Invalid device name ‘/dev/ttyUSB0’. Must be ‘DEVICETYPE:ADDRESS)

  3. Install Intertechno Binding via PaperUI

  4. open /etc/openhab2/services/culintertechno.cfg an add:
    If your Stick runs on USB0 - otherwise find to which port it belongs: ->

sudo reboot


sudo service openhab2 restart
  1. With
tail -n 1000 -f /var/log/openhab2/openhab.log

you can look up if your CUL is supported now.
The message

2017-10-20 22:29:03.737 [WARN ] [io.transport.cul.CULLifecycleManager] - CUL config is NULL, doing nothing

ISN´T A FAILURE OF THE CUL!!! Your Cul will be recognized. Also that the CUL is initialized to ttyUSB0 is normal!
Other posts installing to ttyACM0 / Serial0 / AMA0 belong to Raspi 2 or other.

Raspberry pi3

has a WiFi Port and a Bluetooth Port - these are blocked on AMA0 and other ports.

  1. Now go to: and look up your equipment. In most cases Original Intertechno works for some devices not listed.

  2. .items file
    Switch Schrank_klein “Schrank Klein” (gSchalterWohnraum) {culintertechno=“type=raw;address=FF00F0000F;commandOn=FF;commandOff=F0”}

  3. If you no configuration done with this codes work install minicom

sudo apt-get install minicom

and start it with:

minicom -s -c on

Configuration is 38400 / 8 / 1 / N

then exit and save and start again with


Pressing SHIFT+ V should give you the version and firmware of the CUL
Pressing X21 (yes you have to type it…and you don´t see that you are typing) enables the sniffing of the CUL
Now you will get some code fences.
If you are lucky - Press desired button on your Intertechno Remote and minicom shows a code like:
This code can be converted to a format openhab needs: try is is6435457654515454545.
If python is not installed…google to install it.

You can also do a try and error now because minicom also sends codes you are typing:
just type: is000000000FFF (Enter) for switching on A1 - It was my luck that esp. this code worked directly.
Use it in your .items file WITHOUT “is” and FF for command on and F0 for Off

Thanks to @opus and @dartrax


Hello @Marko_Kraft,
thank you and @opus for your work! I finally got the time trying this for myself.
I used Openhabian, too, so I cannot say anything about that “(Invalid device name ‘/dev/ttyUSB0’. Must be ‘DEVICETYPE:ADDRESS)”-Error.
To get it working, I needed to add the serial configuration to /etc/openhab2/services/culintertechno.cfg, like this:


Without that, my IT switch would not work.
Now I’m just waiting for someone implementing IT receive functionality into the IntertechnoBinding… :wink:

It was hard work :wink:
Anyway…stuck in alexa and cul. I have created a group in the Amazon Alexa group which switches all lights on. After switching about 8 Intertechno devices (one after another) the culs red light is blinks rapidly. Green light is off. The cul hangs up. I have to restart the whole system then.
Manual switching always works fine.

That could be either he separate threads that try to use the CULat the same time ( because each send is run in a separate thread) or the build-in limit of messages per time in the CUL. More probably the first one.
A way to overcome is to look if the used switches do allow a ALL-OFF command (not all have that). Otherwise only a rule that switches one after the other with a sleep in between will help.

Hallo together

over the last week i started with openhab, mi goal is it to migrate mi old “system” from smartwares and Intertechno in to openhab and extand it.
i have the follow components:

i readed a lot in the community but i couldn’t bring it to work with the raspberry pi 3 and a busware cul 433MHz USB dongel. I configured the dongel how in this description:

  • Youtube - watch?v=nMqaZkV_Ols

My my culintertechno.cfg looks like this:


the intertechno.items like this:

Switch  Schalter_Wand     "Licht Wand"       {culintertechno="type=raw;address=0000C49FO1;commandOn=FF;commandOff=F0"}
Switch  Schalter_Stern    "licht Stern"      {culintertechno="type=raw;address=FF00FF00FF;commandOn=FF;commandOff=F0"}

and the test.sitemap like this:

     Text label="Wohnen" icon=sofa {
         Frame label="Licht"{
             Switch item=Schalter_Wand label="Wand" icon=switch
             Switch item=Schalter_Stern label="Stern" icon=switch

The upper code i got from the Smartwares-System. If i now Switch “Wand” in de Basic UI the green LED of the CUL is making a short flasch but nothing happens (usualy the LED of the CUL is togeling from green to off, in a clock of 0.5s) the same is happening if i try to get the “Stern” (with the new code).
I would be very thankful for some advice.

What is the logfile output concerning the cul. YOU Can see it in the startup logfile of your openhabian. Otherwise look through my former postings. I described the nearly the same configuration and completly solved the Intertechno and Cul thing.

ACM0 will definately not work.

Why shouldn’t that work? It depends on how the CUL is connected, my CUL(866) is connected as ttyACM0 and is working!

Your culintertechno.cfg is WRONG!
The syntax you copied is from OH1, which used a single config-file for all addons. OH2 has dedicated files for each addon, like your culintertechno.cfg.
Just remove the “culintertechno:” in each line!

I’m not terribly sure that the code for the first ligth would work!

I read sw. that ACM0 belongs to Rpi2 … for Rpi3 it´s USB0

I had used the CUL (866) on a Raspi2 as I use it now on my Raspi3 as ttyACM0!

I get it work now… i removed the “culintertechno” in the culintertechno.cfg:


# How often should the command be repeated? (optional)
# See for details

# How long should one pulse be? (optional)
# See for details

and changed the configuration in the intertechno.items to:

Switch  Schalter_Stern    "licht Stern"      { culintertechno="type=raw;address=01010110000100010110010110;commandOn=010000;commandOff=000000" }

and the rest was okay, in this case the config “device=serial:/dev/ttyACM0” is working well.

Now i have just to figure it out how to dim the intertechno ITDM-250.

Thanks to @opus and @Marko_Kraft for the fast support

You’re most welcome and real lucky to get it working.
Since I used a 866mhz CUL so far, I decided to switch to a 433 nanoCUL. This one comes on as ttyUSB0 and I can’t get that one to work with OH😣

What’s wrong? I got 433 and 868 nanoCUL running in parallel.

What is interesting, in both cases I am using ttyUSB0 or ttyUSB1.

(I have not confirmed if 868MHz is really working because I am not controlling anything).

Can’t say what’'s wrong besides that the nanoCUL is not sending from OH.
I’ll have another test-session tonight. Will report back.

Yeah, I recommend first checking that openhabian or your user loading OH is part of the dailout or TTY group.
I had the same issue recently on Ubuntu when programming my EPS8266 over FTDI (which will also show up at /dev/ttyUSBx).