New Aeotec Door/Window Sensor 7 not in Database yet?

Tags: #<Tag:0x00007f4341c2f200>

n00b question but is the zwave binding in the milestones?

I used to have it manually installed after I helped add something to it but went back to the “production” version after 2.4. If I get the milestone release will I get the new zwave binding or do I need to go back to manually installed?

Cheers! :slight_smile:
=C=

@calevans
do you plan to install the sensor with security on? If so, I will wait for your install before I try again. Secure include did not work for me about 3 weeks ago.

The latest zwave binding will be in the snapshot release only (until there’s a 2.5 M2 release to pick it up).

You can install it manually, or you can try to update it as described in my post here.

1 Like

This did NOT work for me. :slight_smile:
Well, somethings changed. Here’s what I did and what happened.

I followed your instructions. The first time it failed but it seems to have been a permissions issue with the old 2.4.0 jar file. I made it world writable and then tried again and it worked…kinda.

Now I have ZWave installed via PaperUI I don’t know if that’s important.

The FIRST time I got the upgrade on the console to work, everything seems to have worked just fine. I used the command:

bundle:update org.openhab.binding.zwave https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/binding/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar 

Then I checked the results with:

list -s | grep zwave

So far, so good, it listed the 2.5.0 jar with a long string of numbers that I assume is the snapshot or build number.

I rebooted my system.

Everything came back up.

I went back into the console and issued the ls command again and it was back to 2.4.0. :frowning:

So I tried the update again.

Everything seemed to have worked, it was showing the 2.5.0 again. BUT. I got distracted for a few minutes and then just to make sure, I did the ls command again and it was back to 2.4.0.

Long story short, I could not get it to stay on 2.5.0. I eventually uninstalled it form the console, uninstalled it from PaperUI, rebooted and reinstalled 2.4.0 from Paper UI. (I cut out about an hour of banging my head on the monitor and trying different permutations.)

I now have 2.4.0 up and running just fine but obvs, I can’t use the sensors yet. :slight_smile:

Have you ever seen it where the upgrade works but then it reverts to the older version? That jsut seemed odd.

Nothing else is running on this system, it’s a little RPi dedicated to openhab.

Thots?

Cheers! :slight_smile:
=C=

I’ve not seen that behavior before. I suppose you could fall back to manually installing the jar in the addons directory.

That is the proper procedure or use the script.

@calevans, have you editted the binding line in your addons.cfg file? I vaguely remember this happening to me when trying out bundle:update.

So is the Karaf command bundle:update

2 Likes

OK, still learning… :frowning:

Excellent idea @5iver, thanks. I checked my addons.cfg and no, there is nothing there.

Cheers! :slight_smile:
=C=

That worked! :slight_smile: Ran the script (still had it from the last time I did this during the 2.4 milestone days)

Cheers! :slight_smile:
=C=

1 Like

It seems that “That Worked” only applied to getting the current Z-Wave binding installed. :slight_smile:

I am currently running

274 x Active   x  80 x 2.5.0.201907292154     x org.openhab.binding.zwave

Which I believe is the current snapshot release. (Although I will admit that it may not be as I can’t figure out how releases are tagged on the github repo)

If, using PaperUI, I go to Configuration->Bindings->Z-Wave and in the search box I enter ZWA008, it does come up. So far, so good.

However, when I try to add the device, it keeps coming up as “Device Unknown”. I even used the ZWave diagnostics tool to forcibly remove the node from my controller, rebooted and re-added. Still it does not recognize the switch.

Anyone have any thoughts on what I am doing wrong?

Cheers! :slight_smile:
=C=

@chris or @sihui any suggestions!

I’ve not read through all the messages here to understand what the issue is, but I can comment on the last message -:

Please post the properties that are discovered for the device - or the XML file that is created for the device (from the userdata/zwave folder). There are 2 reasons why this can happen (I think it will show these reasons in PaperUI when the device shows as unknown?).

  1. The device isn’t in the database
  2. The device isn’t fully discovered

If it’s the second one, then you need to wake up the device a few times so that it is discovered. Otherwise, please post a debug log showing the inclusion.

Hi @chris ! :slight_smile:

Ok, it’s been a while since I’ve done this but I think I got what you needed. Attached is a portion of my openhab.log and the network_db66087b__node_33.xml file. There was no node_33.xml file.

Also, yes, PaperUI tells me that the problem is one of the two but it does not state WHICH of the two it is. :slight_smile:

Thanks for your help.

Cheers!
=C=

network_db66087b__node_33.xml (12.5 KB) zwave.log (413.7 KB)

Thanks.
That is what I meant when I said the file ENDS WITH … I did not know your network id number. :wink:

1 Like

@sihui @chris I think I see the issue. This looks like the sensor. I think we need to add a reference 0102:0007 to recognize this particular device.
It looks like it was not completed.

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1065

EDIT: Pasting the xml file did not work so I will try to update some manually.

1 Like

Hi @calevans,

Once you get yours up and running with this new device; I plan to roll it out in my house. I currently don’t have any door sensors but have a lot of other Aeotec zWave stuff in the house.

LMK when your is working :wink:

Best, Jay

1 Like

I love All the Aeotech stuff I have. When I get these up and running I will most likely replace the Sensitiv strips I currently have with the new Door 7’s. Better solution and a field serviceable battery. :slight_smile:

Now if I could jsut get my hands on a Doorbell 6. :slight_smile:

Cheers!
=C=

@sihui I updated & submitted for review.

1 Like