New binding Resol VBUS

I stopped the cron job, which does cyclic reads until now. There was no lock before I started openhab as root. The lock is done by user root, the cron job does not run as root …

Thanks, Holger

I’m currently using this binding in Openhab 1.8 with a VBus LAN interface.
I would like to move to OH2, but haven’t had any luck getting this to work.
Does anyone have it working in OH2?


Pulled the sources and did a lot of hacking.

At the end I found out, that my .item file was created on Linux. I added one line on Windows, which adds a line with CR LF. This line leads to a failure which stops the whole thing from working.

But, this did not help with the lock failures. I get these failures, if I use another binding which uses a serial port. In my case it is the smlreader binding (still in pull request). I am not sure if it is a problem of ResolVBUS or smlreader. It uses a ttyUSB port. But if I use both I get these failures and one of both will not work. Does someone else use another “serial” binding (which uses the along with ResolVBUS?

Tx Holger

Yes,I’m using the Sonance binding I wrote myself in combination with the Resol. I’m also using the DMX binding which has a direct serial connection with USB.

How can i add the

Command to OpenHAB2?
I don’t have a or a directory /opt/openhab/*

You can add this to /etc/default/openhab2, add the following line:

However, the old binding doesn’t seem to work in openhab2. Is there any news on an updated openhab2 binding with support for serial vbus adapters? I found this one:
but it only seems to support network adapters.

Is there a workaround to get the data in openhab2?

Yes, I use a usb stick from my raspberry pi with some scripts which push the data to MQTT.

To actually read the data from the resol device I use a project which I adopted from Google Code.

If you are interested I can share some more details of my setup?

Thanks for posting that codeworkx binding @nikoraes

I thought it was just what I was looking for, as I have the LAN interface connected to a DeltaSol BS/4.
Unfortunately it looks like my setup is not supported yet.
Does anyone know if there is work being done on that binding? Or if there is another way to get the data out of my setup?

Hello Martin,

I’ve managed to get it to work in the command line, but it doesn’t seem to work in the exec binding (no output). Have you made an additional script to run from the exec binding?

I have a python script which pushes it to my mqtt server, although I see no reason why it should not work with the exec binding. Although I have not worked with the exec binding enough to now how/what we should escape.

I did a complete write down of my setup in case people are interested

How is it that the Codeworkx binding isn’t in the OpenHab addons list? Did someone tested with it? Is it stable?
Is there a compiled version of it we can download somewhere?
I’m using a network adapter (Resol VBUS LAN).

I tried it, but unfortunately was unable to get it working.
The vBus Converter thing sits with status “INITIALIZING” & the Resol Controller “UNINITIALIZED - BRIDGE_UNINITIALIZED”

If you manage to get it working, please let me know how.

Hello @Mitch77,

Could you give any updates on the message above, where you ever able to spent more time on it? Thanks for your update!

I’m stuck with the same same INITIALIZING status for know. So I guess it’s not your installation. It didn’t log anything also. I have to investigate further. Let me know if you find something.

Sorry guys for my late response. I stopped working on the 1.x version and started to work on a new 2.x version. But soon stopped due to time and little experience with the new ESH framework. Feel free to take whatever I did to start something new or rework what has been done. Sorry.

I made some changes and got it working on my installation:
Here is the .jar:

@Laurens, you legend.
Works for me now too!

Great, thanks for the feedback!

Hi folks,

my Resol LAN Interface was successfully connected to my Cosmo Multi controller and I could read the values in my OH1 Setup. Since two weeks I made an update from OH1 to OH2.
It seems that the new inofficially Resol OH2 binding from codeworkx only supports values as described in the README file btw. the devices as mentioned.
When I look in the jar Folder there are all the Xml device specs missing. Also the XML structure has changed, right?

Instead of fields now channels are used, so what has to be done to get other devices connected?

You can add unknown devices like I did here: