New binding Resol VBUS

I am using a Vbus LAN adaptor & a DeltaSol BS/4 controller.
The AdaptorSerial was filled in automatically & is the same as shown in the adaptor.
The controller was picked up automatically & added via the Inbox.

It all used to work ok with the 2.0 version of the binding, but i decided to try with the 2.3 version for the easier configuration & bug fixes.

@Anquietas86 what do you mean with the 2.0 version? - The binding I was working on - which should autodetect and work for theoretically all Resol devices never had a 2.0 version, as I started the development in the 2.3 codebase.

And yes, there is no proper versioning so far, only the name of the jar file which contains a date as I provide them, sorry for that. Do you remember which file was still working?

BTW @Anquietas86 and @Marcel_Duscher, I created a ticket (#19) for that in my github repo, maybe we can track the updates on it there.

Just realised it wasn’t yours, it was the one in this post:

Ah, sorry for the confusion. That is actually a completely different implementation done by @Laurens, but as that was not easy to maintain and my resol device was not supported I just redid a new implementation using the resol-vbus-java library.

Thanks for these valuable informations!
Still my vbus bridge is offline…used the internal private ip address + port 7053 (remote port / live data port) and noted down the serial number from the cgi script…still not online. Is there a reboot-requirement to make it work properly?


Normally no reboot is required, I’d say. But after exchaning the .jar I normally do a restart of openhab (but don’t know whether it would be needed). And between some versions I posted here, it was necessary to remove all things related to the binding and readd them (sorry for that inconvenience - it is work in progress).

Can you try to enable TRACE logging for the binding? For me it worked by adding the follwing to file /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg

# Resol logger = org.openhab.binding.resol
log4j2.logger.resol.level = TRACE # set back to INFO or WARN after you made it work
log4j2.logger.resol.appenderRefs = stdout
log4j2.logger.resol.appenderRef.stdout.ref = STDOUT

OK will do. can you please also check this log in my openhab.log when starting the system…

I think I have seen that also and fixed it already…

I published the binding now in the Eclipse IoT Marketplace and started a new thread for general discussions about my binding.

If you see exceptions in the logs or other specific problems, please do not hesitate to directly raise a ticket on github.

Also do not forget to scroll through the freshly written README and the GETTING_STARTED documentation. As usual every comment is warmly welcome.

@ramack … i found out what was the problem right now. despite to what i have seen in DL2 config (port 7053) i now tried the default value of 3000 + vbus as pwd…and it works. sorry for the “drama” - hope this feedback may save some other’s time. Cheers

@norbert_jordan great, thx for the feedback. Did you already install the latest version I published two days ago in the Marketplace?

@Marcel_Duscher that version could also solve your issue, please try it when you have time.

I installed your latest version today and tested with both BX an FK.
For me it is running fine now. OpenHAB is receiving regualar state changes for all sensor values. No more Java exceptions.
Good work! Thanks for this quick solution.

From my point of view, issue #19 can be closed (

@ramack thanks for the information about the market source. I’ve seen it when i read your great intro doc online. As i’m not familiar with the IOT market,…i guess first i have to remove the JAR file and readd it via paperui…

But will - due to the market - the JAR be updated in background automatically whenever you add something new? or how does it work in the market case if i want to update to the latest version?
Or is this the greatest advantage + maybe not necessarily remove and add things after each update…

Thanks Norbert

Honestly I don’t yet know how it will behave with updates, but I do not expect, that they are just magically pulled into your installation. The need to remove and readd the things is only due to changes in the channel types. I hope this is not needen in future. The marketplace will not help here. That just simplifies the setup, as you don’t nees to handle the jar files manually.

I have just removed the jar file & installed it from the marketplace instead, now seems to be updating fine.

Once again a big thank you for the openhab 2 update, it works perfectly in my OH 2.2 with a Resol Vbus Lan adapter connected to a Cosmo Multi 2 heating controller. This was the last missing binding to run a successfully working openhab 2 instance for me!! Great

Do you know if the RESOL VBUS binding is working with the RESOL KM2?
If it’s working for you, could you explain me your configuration? What’s your vbus bridge config? I can’t connect the binding and KM2 :frowning:
Thank you


I myself have only a VBUS-LAN interface (as I understand the predecessor of the KM2), but I would expect, that it should work also with KM2. Normally I would hope, that after adding the binding a new thing - the VBUS-LAN bridge should be automatically found.

  • Was that the case?
  • If you have it, the only thing that you normally need to adjust is the password. - And the binding intentionally even doesn’t try the default password, because I strongly recommend to change that.
  • Do you know the IP address of your KM2? - Did you a assign a static IP (either in the KM2 web interface your your router/DHCP server)?
  • Can you do a nmap scan of that IP and at least the port 7053?
    nmap -p 7053
  • Can you telnet this port if it is open and see whether it responds with something like
Trying <KM2-IP-ADDRESS>...
Connected to <KM2-IP-ADDRESS>.
Escape character is '^]'.
  • You might want to add and configure the bridge thing manually, normally the IP address should be sufficient (beside the password).
  • Last but not least, what do you really see and what do you expect?

Hi @ramack,
Thank you for your quick reply. Here are some more details:
two things are created:

  1. The RESOL device, named “Resol KM2”
  2. The “Bridge VLANBus Adapter”

In the Resol device, I’ve manually configure it to use the “Bridge VLANBus Adapter”.
The IP address of the device is FIXED :

The 2 things are OFFLINE. The Device says it’s due to the adapter … Logic :’) but on the “Bridge VLANBus Adapter”, there is communication error: “Server returned HTTP response code: 502 for URL:

I’ve manually tested this URL, and, indeed, not a valid one. The response is :

Bad Gateway
The process did not produce any response

A full nmap command on the device:

Initiating ARP Ping Scan at 10:49
Scanning [1 port]
Completed ARP Ping Scan at 10:49, 0.31s elapsed (1 total hosts)
Initiating Parallel DNS resolution of 1 host. at 10:49
Completed Parallel DNS resolution of 1 host. at 10:49, 0.01s elapsed
Initiating SYN Stealth Scan at 10:49
Scanning [65535 ports]
Discovered open port 8080/tcp on
Discovered open port 443/tcp on
Discovered open port 53/tcp on
Discovered open port 80/tcp on
Discovered open port 22/tcp on
Discovered open port 1883/tcp on
Discovered open port 7053/tcp on
Discovered open port 57053/tcp on
Completed SYN Stealth Scan at 10:49, 8.97s elapsed (65535 total ports)
Initiating Service scan at 10:49

Result of the NMAP -p 7053 command:

7053/tcp open unknown
MAC Address: A8:40:41:18:FB:27 (Dragino Technology, Limited)

And indeed, the TELNET command is working.

So, my guess is that the requested URL is not working on the KM2 device and that the VBUSLan Adapter is bloquing on it :wink:

Thank you for your help. Do you need additional information?

Wow, that was a good set of data you provided here. I think I know what’s going on, an created a ticket for the used library. Please give us a few days to check and fix it…