New Binding: Vallox MV ventilation unit series

Greate to hear that it’s working.

In paper UI those channels should be listed if you display although advanced channels.

Sorry, little blackout! You’re right. All channels will be shown after clicking on “show more”…

Hi Björn,

it seems, that the binding is not working anymore with OH 2.5.0 M3. The binding is installed but not listed in paperUI under installed bindings. The thing is still online but there are no items available. can you please check this and if you can reproduce this error maybe there is a way to fix it.

It can’t be the binding’s fault if your items are missing. You must have deleted them.
I’m using 2.5M3, too with no problems.

Hmm, both files (.items & .things) are equal to the files on my 2.4 system. I checked it with the todays snapshot version and there is the same problem. my things-file looks like this:

Thing valloxmv:valloxmv:07bcc33d "Vallox Lueftung" [ip="", updateinterval=60]

Is there something wrong? Can you please post your thing-file? Is something else necessary in 2.5 that wasn’t relevant in 2.4?

Here a part of my items-file:

Switch ValloxVentilationUnit_AnAus “Status” {channel=“valloxmv:valloxmv:07bcc33d:onoff”}
Number ValloxVentilationUnit_Profil “Profil [%d]” {channel=“valloxmv:valloxmv:07bcc33d:state”}
Number FanSpeed “Fanspeed [%d %%]” {channel=“valloxmv:valloxmv:07bcc33d:fanspeed”}

I am having exactly the same problem as Arne with 2.5.0 (stable release version) after upgrading from 2.4.0 today. Did you find any solution to your problem in 2.5? My Vallox is a 350MV.

The binding hasn’t been touched for quite a while (beside the move to the new build system).
Have to check myself when doing the upgrade over Christmas days.

Thanks for looking into this issue. I compiled some information regarding the addon that I could find. First of all I don’t receive any error message in openhab.log. If I set events to INFO the following messages are found in events.log:

2019-12-17 12:37:23.808 [hingStatusInfoChangedEvent] - 'valloxmv:valloxmv:lueftung' changed from UNINITIALIZED to INITIALIZING
2019-12-17 12:37:23.839 [hingStatusInfoChangedEvent] - 'valloxmv:valloxmv:lueftung' changed from INITIALIZING to UNKNOWN
2019-12-17 12:37:24.876 [hingStatusInfoChangedEvent] - 'valloxmv:valloxmv:lueftung' changed from UNKNOWN to ONLINE

In PaperUI it looks a bit odd because in “Configuration -> Binding” the binding is not listed at all. Under things it is listed without a description:

The bundle is loaded in Karaf:

248 │ Active │  80 │ 2.5.0                   │ openHAB Add-ons :: Bundles :: ValloxMV Binding

Uninstalling and reinstalling doesn’t change the behavior.

If any other info might help please let me know. The addon worked like a charm in 2.4.0. I didn’t change the configuration after updating to 2.5.0.

Hi Björn,

I have the same problem as Rene with update from 2.4.0 to 2.5.0 my Vallox.
The logs are the same as Rene.
I use Debian 9 with zulu-8.
Thanks if you can help.

log:set debug org.openhab.binding.valloxmv

@mstormi Thank you, that helped to get more details.

Here are the results:

2019-12-19 08:00:51.931 [DEBUG] [ng.valloxmv.internal.ValloxMVHandler] - Schedule vallox update every 60 sec                                                            
2019-12-19 08:00:51.933 [DEBUG] [ng.valloxmv.internal.ValloxMVHandler] - Connecting to ip:                                                               
2019-12-19 08:00:51.959 [DEBUG] [.valloxmv.internal.ValloxMVWebSocket] - Connecting to: ws://                                                          
2019-12-19 08:00:52.663 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Connect: /                                                                       
2019-12-19 08:00:52.703 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Got binary message                                                                             
2019-12-19 08:00:52.711 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Response length: 1410                                                                          
2019-12-19 08:00:52.713 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Fan Speed: 50                                                                                  
2019-12-19 08:00:52.807 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Data updated successfully                                                                      
2019-12-19 08:00:53.671 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - WebSocket Closed. Code: 1005; Reason: null                                                     
2019-12-19 08:01:54.159 [DEBUG] [.valloxmv.internal.ValloxMVWebSocket] - Connecting to: ws://                                                          
2019-12-19 08:01:54.237 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Connect: /                                                                       
2019-12-19 08:01:54.248 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Got binary message                                                                             
2019-12-19 08:01:54.253 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Response length: 1410                                                                          
2019-12-19 08:01:54.255 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Fan Speed: 50                                                                                  
2019-12-19 08:01:54.271 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Data updated successfully                                                                      
2019-12-19 08:01:55.228 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - WebSocket Closed. Code: 1005; Reason: null    

FYI, got a message from Vallox support yesterday saying they’ll release v2.0 beginning of next year, to include major improvements on the MyVallox cloud service. That now we’re probably not interested in but I guess it can bring a number of new issues.
Following up, my contact at Vallox has let me know this:
We have (finally) decided that the websocket protocol will be public, and the protocol documentation will be released at the beginning of 2020. The problem has been that the protocol is autoregenerated at compile time and therefore too unstable to be supported officially. But now we decided that the current single register commands etc. will be frozen so that they will not change in the future. There are many bindings/implementations for it already and we do not want to break them in every firmware update (and I have already tried to keep the protocol as it is). So, we will make a public protocol description which will be stable in the future updates.

1 Like

Hmm, that looks super normal.

I took a clean docker instance of 2.5 and installed the vallox mv binding, but I was not able to install any vallox mv thing as no line item for it is displayed. Strange.

Created a issue to follow up in github

Seems like a typo in folder name did prevent the addon from working correctly. Sorry for that.

Patch is in the pipeline for a 2.5.x release. Download can be found here.

@bjoernbrings Thank you Björn, that jar is working for my setup (350MV). Just copied it to the addons folder and openHAB is immediately reporting the correct values.

Wish you a happy New Year, Rene

1 Like

Vallox just informed me that they’ll release v2.0 of their firmware next week.
They say that if your system is registered with and connected to the myVallox cloud it’ll automatically update.
My developer contact said they’re not gonna change modbus variables from now on but I’m not 100% sure what ‘now’ is.
So the binding may or may not continue to work with units when you update to v2.0.
(and if you don’t want that to happen automatically, log out of myVallox cloud)

Hi there,
first of all, thank you very much for this binding, @mstormi :+1:

Have anybody of you already updated your Vallow to the v2 firmware and can confirm that everything keeps working? I’m a bit anxious to upgrade :slight_smile:

It wasn’t me. Thanks go to @bjoernbrings.

I just logged into the cloud service, and seems it updated my box right away? I didn’t even notice.
Seems to be working fine.


@bjoernbrings Hi Björn, I have Vallox 145 MV and binding works. I am however missing some functionalities from binding hence I’d like to propose these improvements:

  • for timer profiles, use timer value from that profile settings instead of “hardcoded” value in binding code
  • for timer profiles, add possibility to enable or disable timer in profile setting
  • add support for 3rd timer profile: Programmable profile (i.e. EXTRA)
  • for Fireplace and Programmable profiles, add possibility to set fan speeds in profiles settings
  • add support to enable/disable weekly timer

Additional variables to be supported for Fireplace profile:
A_CYC_FIREPLACE_EXTR_FAN : extract fan setting (%)
A_CYC_FIREPLACE_SUPP_FAN : supply fan setting (%)
A_CYC_FIREPLACE_TIME : timer in minutes setting, use this value as timer value when changing to fireplace profile
A_CYC_FIREPLACE_TIMER_ENABLED : timer enabled setting (1/0)

Additional variables to be supported for Boost profile:
A_CYC_BOOST_TIME : timer in minutes setting, use this value as timer value when changing to boost profile
A_CYC_BOOST_TIMER_ENABLED : timer enabled setting (1/0)

Programmable profile variables (similar to Fireplace profile variables):
A_CYC_EXTRA_EXTR_FAN : extract fan setting (%)
A_CYC_EXTRA_SUPP_FAN : supply fan setting (%)
A_CYC_EXTRA_TIME : timer in minutes setting, use this value as timer value when changing to programmable profile
A_CYC_EXTRA_TIMER_ENABLED : timer enabled setting (1/0)

Weekly timer enable/disable variable:
A_CYC_WEEKLY_TIMER_ENABLED : timer enabled setting (1/0)

Regards, Antti

Hi @bjoernbrings, thanks for this awesome addon. I am using it with my 350MV. According to the latest documentation there is a switch listed for changing the status of the weekly timer (on/off):
weeklytimerenabled - A_CYC_WEEKLY_TIMER_ENABLED

I have OpenHAB 2.5 installed and updated the ValloxMV addon to version from your snapshot repository.

Unfortunately OpenHAB doesn’t show any data for this item and if I use PaperUI to list the available channels for the ValloxMV thing it is not listed as well. Did I miss anything to get the weeklytimerenabled channel working?