New Clipsal C-Bus binding

openhab2
binding
Tags: #<Tag:0x00007f51e3fedcb0> #<Tag:0x00007f51e3fedb20>

(Nicolas Somerhayes) #21

I started a clean OpenHab install using the hassle free image for a raspberry pi

I have Cgate working and tested using toolkit, My project is loaded in the tags folder

I have added the latest version of the binding I could find (org.openhab.binding.cbus-2.2.0-SNAPSHOT.jar) to the /usr/share/openhab2/addons folder

but from hear I cannot really work out how I got it to show in the Paper UI

does anyone have any suggestions?


(Matt Shepherd) #22

Hey Nicolas,

How are you getting on connecting cgate to Openhab?


(Nicolas Somerhayes) #23

Hi Matt I have still not worked out what I am doing wrong, I kind of remember last time I set it up after adding the binding to the addons folder the binding automatically shown in the Paper UI inbox but I cannot seem to find it.

Maybe I should try a manual install of openhab instead of the hassle free image?


(Matt Shepherd) #24

Yeah the binding should show in your bindings on Paper UI, are you logged in as openhabian?


(Matt Shepherd) #25

Also make sure it’s a jar file not zip


(Nicolas Somerhayes) #26

I got it to show I think it might have been a file permission problem as I copied the file from my Mac to the Openhab server using a SMB connection however I downloaded it directly using wget and it worked.

Now I have another problem cgate shows as online but network is showing UNINITIALIZED - HANDLER_INITIALIZING_ERROR and I think I have seen this before but cannot remember how I solved it.
I have copied the C-Bus Tag file across to the raspberry pi are there any other configuration files I should copy over to the raspberry pi CGate server?


(Matt Shepherd) #27

There should also an access file on your mac?


(Matt Shepherd) #28

And sometimes you just need to restart the cgate service on the pi. Restart OH too.


(Nicolas Somerhayes) #29

Hi Matt I got it working it was another permissions problem the Tag file was not owned by openhabian but once I change that it was all go. I guess I just need to ve careful when using SMB to transfer files this is the second time this has caught me out

All seems to be working well thanks for your help


(Matt Shepherd) #30

Cool. There is an option on openhabian-config to fix permissions.


(joshpond80) #31

Finally getting around to trying this out and playing around with it.

Not a real bug so to speak but for others who might come across this. I’m finding when going through paperUI that the autogenerated Item Name starts with a number. (The group number)
This can lead to an issue with rules as per my post below.

https://community.openhab.org/t/rule-with-item-that-starts-with-a-number-not-running/41608/1

I’ll go back and manually set the names but not sure if it’s possible to have the Item name that is auto created have the number at the end instead?

Thanks Josh


(Matt Shepherd) #32

Hey Josh, that annoyed me when I first started using openhab but it’s just the thing Id that has the cbus number at the beginning but the items do not and that is what you use in the rules. I actually use a cbus items file so when you discover the things the items are already attached, saves time especially if you have 60+ devices.


(joshpond80) #33

I’ll double check but the thing definitely has the number at the start but for mine the items did too.
When I went to link the thing and used the “+create item” it just starts with a number first. I just move the number to the end of the item name.
No biggy, just extra work.
Thanks to


(Matt Shepherd) #34

Oh ok, maybe make yourself an items file instead of using paper ui. Saves a lot of button clicking especially if you have to keep starting over. I’m not sure if you have Kodi? But I have some cool ‘night-time’ rules to dim lights when a movie starts but only when the sunsets. Pretty cool.


(joshpond80) #35

I was lucky in that I only added a handful of items before testing so only had to fix a few up.
For those who read this, it’s not difficult using the paperui;
Add as thing is fine with the number at the front. When you link the thing to an item name, the suggested item name just has a number at the front, I cut and paste that at the back of the name. On that page I have to type a label anyway, otherwise everything would be called ‘light channel’

I do have Kodi but not cbus everywhere yet. In the middle of reno/testing. Needing money…
I did have at the previous house when pausing the movie that the lights would come on and that sort of stuff. It is cool, that’s why I do this. The amount of time spent setting it up I don’t think I’ll ever save with these short cuts…

Josh


(Nicolas Somerhayes) #36

Hi Has anyone integrated Amazon Alexa to control there Cbus lighting using an amazon echo?

if you have can you please post a copy of your .items file


(Kevin Adcock) #37

Great work. I had c-bus at my previous place. I want to try to do everything this time with bits and bobs I’m going to put together, using RPi’s, OpenHab2 and MQTT.
I’ve got some Saturn switches I’d like to use and wondering if anyone knows if they can be used/controlled directly with OpenHab2 rather than having them connected into a c-bus network?


(Kevin Hawkins) #38

No, that’s not going to work. The endpoints like relays and dimmers implement the smarts on C-Bus.


(Matt Shepherd) #39

Sell them they’re worth a fortune!!


(Matt Shepherd) #40

I’ve just seen your post, I take it you managed to figure it out?