New Device - how to add to database?

I am just switching my big installation from Vera to openHAB. So far it’s going well…but I have some Finesse Mini blinds that show as unknown. They paired fine but don’t have any linked channels…

I see a few other posts about adding things to databases…I haven’t tried any of this yet, but what is the preferred process for this? End users get their systems working and send info to an administrator or end users are trusted to edit the public database?

See the image…

Hey Terry welcome to the OpenHAB community!!!
It looks like your devices are zwave, let just assume you have the zwave binding installed?
is there a vera binding you are using? Tell us about your set up so we can help you get OpenHAB going

Thanks for the reply Andrew.

Yes, I definitely have the ZWave binding installed…I have 50+ other nodes already up and functioning. I am not using any Vera binding because I have already transition to openHAB and powered down the Vera. My issue is that I have a device that does not appear to be in the ZWave database and shows as an unknown device. I am looking for guidance as to how to resolve this. Can I make it known and get it enabled by myself or do I need to wait for someone lease to add this device to the public device database?


You need to add it to the database:

If you encounter any problems please post the generated xml file, a product manual and a product image and someone will add it for you.

1 Like

First check to see if it is already in the database. If you are running the stable or testing version your database is not current.
You can move to the latest binding if your device is in the latest released database.

I can confirm 3007:0001 is not in the database.

1 Like

I just looked and we have no devices from manufacturer 016D in the database.

@tvipond Chris is the developer of this binding and very dedicated here.
If you post the xml and, preferably, a link to an online manual we can get this added.
The hard part is then waiting for it to trickle up to the latest snapshot binding so you can use it. I have been though this process myself.

Correct, I’ve read lots on the forum and checked the database…to no avail…I did come across Chris and that was my next plan…to send him the XML. I’m running the snapshot from less than a week ago.

I am new here so don’t feel comfortable editing the public database myself…until I learn more of course!

Thanks for the replies guys

Here are the XML, a small pdf with description of the product and an image.

I have tried finding some manuals online without luck, but will continue trying if required.

I will wait patiently…let me know if there’s anything else other than a better manual required.


Okay, skip that…I am still classed as a new user and cant send attachments…I will try and resolve that and then send them to you!


Okay, I try again…looks like I passed my probation!

network_cc72b6fd__node_57.xml (8.3 KB)

Finesse.pdf (372.8 KB)



Unfortunately the manual does not provide any information about associations and configuration parameters and I could not find anything in the world wide web.

Wow, thank you for such quick response and for committing your time.

I agree, the information on the web is not great.

So, with the info in the database so far, should the device work, or I have to create my own associations somehow?

Would it help if I tried to resurrect my Vera where I had these devices working and maybe try and read the association fro there?

Yes, it should.
You need to upgrade to the latest zwave snapshot binding once the changes got merged, usually a couple of days.

Does your manual perhaps have any additional information that may be useful. If it does, a scanned copy could be useful.

I will probably do a binding update tonight (I’ll need a break soon from trying o make the development system work! :disappointed:)

1 Like

Then about another day before it hits the snapshot

How can I tell whether the snapshot contains the new database or how can I tell which version of the binding I am running to ensure I have the latest?

I can only assume the database is not merged yet, or I am doing something wrong. Is what I have listed below the correct process for getting the new database?

I followed all the instructions I could find on how to update the binding/database.

I am using the 2.5 Snapshot, installed early last week.

In an effort to update the binding and z-wave database, today:

  • I deleted “ALL” Z-Wave things, with exception of the Z-Wave Serial Controller using PaperUI.

  • I ensured all Items linked to any Z-Wave based thing were gone.

  • I uninstalled the Z-Wave Binding.

  • I deleted all .xml files in userdata\zwave.

  • I deleted the contents of the zwave.log file and restarted the openHAB server.

  • Once restarted, I waited about 10 minutes and checked the ZWave.log file to ensure it was still empty.

  • I reinstalled the ZWave Binding through PaperUI, and once it was done, I let it discover things.

The things I was having issues with were some electric motors that control blinds and drapes…these specific things are Nodes 57 through 61.

I’ve captured and can upload or PM the log if I know for sure I have done everything correct.

If that is indeed the correct process, I will wait a few more days and try again.


Link to the log, if anyone needs it.


Chris updated yesterday but when I checked this morning I could not tell whether the changes made it because they both happened 15 hours previously. I assume the next build (today?) would have the changes. I cannot check from my phone.

Not necessary.

Not necessary.


Not necessary.

You can do this, but it is not necessary.
But at this point you missed the most important step: you needed to download the latest zwave 2.5 snapshot binding version with the database changes merged to it.

That won’t work at all: you installed your old binding again which does not help. You need to download the latest zwave snapshot and drop it into your addons folder. That’s it.